The displayName of the effect and aerender that can be obtained by the script is garbled in Japanese

New Here ,
Apr 16, 2020 Apr 16, 2020

Copy link to clipboard

Copied

From After Effects 2020(17.0), the displayName that can be obtained by the script is garbled in Japanese.
In addition, there are other issues

  • Japanese cannot be specified by app.findCommandId.
  • The characters are garbled in aerender.

Please fix it.

cafeny_0-1587045973940.png

 

TOPICS
Bug

Views

380

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 21, 2020 Apr 21, 2020

Copy link to clipboard

Copied

Hi cafeny,

Thank you for filing this report. Is the displayNamee issue new to the 17.0 version of After Effects or does the script return garbled displayNames in previous versions as well?

 

For the additional issues, please provide:

  • More details and ideally a script snippet which reproduces the issue in app.findCommandId()
  • Steps to reproduce the garbled characters in aerender, as well as OS verison, OS language, and app language.

 

Thank you for any additional information,

- John, After Effects Engineering

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 27, 2020 Apr 27, 2020

Copy link to clipboard

Copied

Hi John,

Is the displayNamee issue new to the 17.0 version of After Effects or does the script return garbled displayNames in previous versions as well?

Only after2020.

Left is 2020(17.0~), Right is 2019(16.1).

cafeny_0-1588002607717.png

 

alert(app.findMenuCommandId("コンポジション設定(T)..."));

2019 return "2007", but 2020 return "0", inJapanese version.

 

Thank you.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 28, 2020 Apr 28, 2020

Copy link to clipboard

Copied

Hi cafeny,

 

Thank you for the follow-up reply. We have confirmed these issues and opened two separate bug tickets: DVAAE-4214864 and DVAAE-4214866.

 

Thank you again for using the Beta, and apologies for any inconvenience these issues have caused.

- John, After Effects Engineering

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 29, 2020 Oct 29, 2020

Copy link to clipboard

Copied

LATEST

This problem has not been fixed as of 2020 (17.5).
Also, the beta version hasn't fixed it.
I am in great trouble because the error displayed in Japanese is garbled and unreadable.
Since aerender is also garbled, it is not possible to find out what the error is.

Due to this issue, 2020 cannot be used for work.
Please fix it as soon as possible.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines