• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

After Effects unbelievably slow, UI and esp. Trapcode. Hardware/Win issue?

Community Beginner ,
Nov 02, 2023 Nov 02, 2023

Copy link to clipboard

Copied

Hi all!

 

first post out of pure desparation...

 

In short:

UI is slow (like often "power point presentation slow" and especially Trapcode plugins are almost unusable. Maxon Support basically said "deal with it" (details see bottom) but these plugins aside it still it runs much smoother on colleagues's slightly older but similar pcs (all HP). My IT's last suggestion was that it might "just" be a Windows issue (Colleagues Win10, myself Win11), although on my private pc (Win11) it is running okay.

 

Pls don't mark this as a pure "Trapcode problem" although this is currently our main issue. I have been using After FX for 20y+ now and notice when the general performance drops, which it unfortunately did over the last versions 😞 - this is the main issue, but they might be related.

We also noticed similar performance drops in the newest Photoshop version - not the topic here but it shows that this might also be related.

 

Thx for your suggestions!

 

Examples:

  1. Selecting a layer in a new project can take up to 1-2 seconds before it is active
  2. Preference window even up to 10sec
  3. Particular takes >30sec to open and <8sec even for minimal changes like "emit 10 instead of 100 particles" no matter what resolution and display quality

 

PC Specs

  • HP Z4 G4 Workstation
  • Intel(R) Xeon(R) W-2225 CPU @ 4.10GHz, 4104 MHz, 4 Cores, 8 logical processors
  • 32GB Ram
  • 2 SSDs (software on one, other as scratch + projects)
  • Nvidia RTX A4500
  • Windows 11 Pro

 

Things I tried + as suggested by my IT - with no avail =>

 

  1. Acc. to my IT it is not a virus scanner or security problem (maybe Win checking some cachefiles constantly?)
  2. No huge workload while opening / previewing -- CPU, Gfx both at 10-20% max
  3. Rendering of Trapcode very slow, also in Media Encoder, even with a 2sec 512x512px comp
  4. Nvidia driver newest - have tried a lot, even The New Feature branch (also the newest one)
  5. Tried several things with windows swap file
  6. Went trough all forums for Afx or Trapcode Particular settings (Hardware acceleration, use GPU in particular and afx settings, max ram, multi-frame rendering off, ...)
  7. De/installed and downgraded Trapcode + Afx (we need 2022 in our company, but for testing I tried 2023 as well - this is even worse for UI!)
  8. Screen resolution, screen scalings
  9. Tried similar particle effects: Particle Playground, Particle Systems 2 - added quickly and work much better even with massive emission
  10. Benchmark Nvidia RTX A4500 looking good as well
  11. Restart after each try
  12. Remove and reinstall without plugins (+ manually deleted all AFX folders I could find)
  13. Starting AFX in admin + compatibility mode
  14. CPU-z benchmark looking ok
  15. RAM, System, Win Integrity test ok
  16. Win + BIOS Update
  17.  Terminating programs via taskmanager one by one
  18. Completely new PC reset

 

As suggested in a similar old post, Adobe Support can only be contacted via Forum, Chat or Twitter.  The "chat with Adobe" link brings me nowhere really - so I'm running in circles.

 

fyi, Maxon support answer:

 

Thank you for contacting the Maxon support team. Unfortunately, what it sounds like you are seeing is just the current performance of the plugin. 
 
This is because in Trapcdoe version 16, we did away with Aux systems and doubled the number of full systems you can have. When you apply and delete an effect, AE has to index every single parameter. That means every parameter for every system, in the case of Particular. Unfortunately, with the added power of emitting from parent systems comes a bit of a compromise in the loading time. As for the playback speed in TC16, we implemented all new air physics that are on by default, so it's running a physics simulation right off the bat. You can get back to the previous behavior by going into Particle > Particle Physics and set Air Resistance to 0.

 

...and this tip did not help at all unfortunately.

 

Again, thanks for your suggestions, I am ready to try anything (my IT permits me to) 😉

Peter

Bug Unresolved
TOPICS
Troubleshooting , UI and UX

Views

29

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation