• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Generate: Fill effect ignores masks in AE 23.2 - Bug

Participant ,
Feb 23, 2023 Feb 23, 2023

Copy link to clipboard

Copied

In previous versions of after effects, the Generate: Fill effect always respected layer masks, including feathering and expansion applied to those masks.  In AE 23.2, the Fill effect ignores all masks.  It is not a solution to use the parameters of the effect where one can specify masks as settings, as these ignore the mask properties like feather and expansion which may be different for each mask.  I have an entire library of existing projects that are now broken because of this.  I commonly use a layer as, for example, a vignette and then adjust its color with the Fill effect which can be keyframed and expression linked and which does not require editing solid settings to change the color.  Now all of those comps appear with an unmasked, fully opaque layer.  

 

Please fix this effect to restore the behavior it has always had in the past.

 

AE 23.2.0 on Macbook Pro M2 Max Ventura 13.0

Bug Needs More Info
TOPICS
Compositing and VFX , Troubleshooting

Views

39

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Feb 23, 2023 Feb 23, 2023

Hi @davidb46026235,

Thank you for reporting this issue. Would you be able to provide a project file with the Fill effect setup as you've described? Screenshots of how the project would render before and after 23.2 would be helpful as well as we try to diagnose the issue.

 

Thanks for reporting this issue and for any further information you can provide, 

- John, After Effects Engineering Team  

Status Needs More Info

Votes

Translate

Translate
2 Comments
Adobe Employee ,
Feb 23, 2023 Feb 23, 2023

Copy link to clipboard

Copied

Hi @davidb46026235,

Thank you for reporting this issue. Would you be able to provide a project file with the Fill effect setup as you've described? Screenshots of how the project would render before and after 23.2 would be helpful as well as we try to diagnose the issue.

 

Thanks for reporting this issue and for any further information you can provide, 

- John, After Effects Engineering Team  

Status Needs More Info

Votes

Translate

Translate

Report

Report
Participant ,
Feb 23, 2023 Feb 23, 2023

Copy link to clipboard

Copied

LATEST

Hi John,

 

What a fast reply!  Thanks for your ongoing monitoring of this forum.

 

Right after I posted I saw that there was a new update to AE 23.2.1 that had just showed up, and I installed it along with the updates for Premiere and Media Encoder to the latest versions, and, the issue seems resolved!  I am not able to reproduce the issue that I was seeing just prior to the update. I'm not sure if this was specifically fixed or was somehow related to another fixed issue, but thank you for this update.

Votes

Translate

Translate

Report

Report