• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
13

Layer is deselected when creating the first keyframe

Community Beginner ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

Good morning, I have the most up-to-date version of After Effects, 24.0, and the most up-to-date version of Mac Os Ventura, 13.6. And I started facing the following problem. Whenever I use the shortcut to create a keyframe, the layer is automatically deselected (Attached is the video where I show it). And the most bizarre thing: this only happens when I create the first keyframe for each attribute. From the second of the same attribute this does not happen again.

image.gif

Bug Fixed
TOPICS
Crash , Performance

Views

997

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 26, 2023 Oct 26, 2023

Hi all,

 

This issue has been fixed in the After Effects version 24.0.1. Update your After Effects if it's not already.

Let us know if you experience the issue in 24.0.1.

 

Thanks,

Nishu

Votes

Translate

Translate
25 Comments
Adobe Employee ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

Thanks for posting this. We can reproduce and will see what's going on. 

Status Acknowledged

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

Ok, friend, if you need any other information, I'm available to help.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

I also found it out as a bug, because most of times I move keyframes immediately after creating them 😕 It destroys a workflow

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

Sorry about this bug. A fix was made in our internal builds overnight, and that fix should be in 24.1 beta builds by the end of the week. Unfortunately there isn't a workaround in 24.0 that we know of.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

Thank you for your support. I'll wait for the update

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 13, 2023 Oct 13, 2023

Copy link to clipboard

Copied

Hi. Since updating to the latest version of After Effects (24.0.0 / Build 55) adding keyframes with shortcut keys (ie Alt + t to add Opacity keyframe) then deselects the layer, so can't quickly add another keyframe for Postion/ Scale/ etc. without having to first click on the layer again. This behaviour definitely seems new to this version, as I've regularly added multiple keyframes to layers without having to reselect before now.

 

Related to this... If keyframes are accidentally added to all layers because none are seleced when the keyboard shortcut is pressed (because the target layer has now been deselected!), 'Undo' removes one keyframe at a time, whereas previously it would remove all keyframes added with that keystroke in a single Undo.

 

System info...

Windows 10 Home

Intel i9-10900X

64 GB RAM

2 x Nvidia 2070Super GPUs, with up to date drivers

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 13, 2023 Oct 13, 2023

Copy link to clipboard

Copied

Hello.

Thanks for reporting the issue. We are aware of this issue and working on it. We will have a fix for this very soon. 

Thanks and Regards,

After Effects QE

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 13, 2023 Oct 13, 2023

Copy link to clipboard

Copied

We are aware of this issue.

Status Acknowledged

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 13, 2023 Oct 13, 2023

Copy link to clipboard

Copied

Hello,

I always do alt + S or P or T while animating and I came across an issue that After when I have a selected layer the second alt + keyframe goes on All layers. Really anoying and on top of that when I want to redo it redoes it one by one, not the whole multikeyframe activation in one. So I'm there pushing my CMD + Z forever. Please fix it, before I never had an issue like that. Thank you!

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 13, 2023 Oct 13, 2023

Copy link to clipboard

Copied

Ok. Thanks

Votes

Translate

Translate

Report

Report
New Here ,
Oct 14, 2023 Oct 14, 2023

Copy link to clipboard

Copied

Also uninstalling 24.0 doesnt work for macbook at least. If you transfered your project to new version (Apple Arm64), when you reinstall older versions your projects doesn't work. Please release the update quick we are suffering 🙂

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 14, 2023 Oct 14, 2023

Copy link to clipboard

Copied

You should be able to do a Save as version 23.x from the File menu to get a project that works with AE 23.

We are targeting the fix going to 24.1 beta later today, and a 24.0.1 release by the end of this coming week.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 14, 2023 Oct 14, 2023

Copy link to clipboard

Copied

24.1x54 is rolling out to CCD in the Beta section over the next 20 minutes. It contains a fix for this issue. If you're able to try it out and confirm the fix is working for you, that will help us get this fix out in a 24.0.1. Thanks.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 15, 2023 Oct 15, 2023

Copy link to clipboard

Copied

2023 Version:

when I keyframe with Opt+Shift+(Key), the layer will be selected.

 

2024 Version:

it automatically cancels the selection of the layer after keyframe with shortcut key.

 

I'm not sure if this is a new feature or a bug. Could you please explain or fix it?

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 15, 2023 Oct 15, 2023

Copy link to clipboard

Copied

It's a bug. Search the forums and you'll find a few reports of it. It is fixed in the 24.1 beta and we are looking at a 24.0.1 release this week to fix this. 

Status Started

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

I'll download the new version to see if everything is ok, I'll be back with the results soon. Thanks!

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

Good evening, I tested the beta version of After Effects (24.1) on Mac Os and Windows and the problem is corrected as shown in the attached video. I would also like to talk about the new functions implemented (I don't know if it's just in the Beta, but I hope it continues for the final version) which are these new buttons in the top right corner of the software that show what's new in the program and the other which gives access to the Adobe and After Effects community, and also the possibility of reporting bugs. As shown in the attached image. Congratulations to whoever developed it. It seems like a small change, but it will definitely make a big difference.
Thank you @jenkmeister  and Adobe team.

Sidneytsilva__0-1697501544425.png

 

Votes

Translate

Translate

Report

Report
New Here ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

Yes I've had this since updating and it's super annoying

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

The issue is fixed in 24.0.1 if you can update.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 26, 2023 Oct 26, 2023

Copy link to clipboard

Copied

When a layer is selected, and I apply a keyframe with a keyboard shortuct, the layer automatically is deselected.

 

It only happens on the very first keyframe for the coorisponding attribuite.

 

For instance, if I have a new layer and I want to animate the opacity, I selecte the layer, hit option > shift > T, a keyframe is applied but the layer deselects. I jump ahead in the timeline with the shortcut, control > shift > right arrow, and set another keyframe, it sets a keyframe for every layer in the timeline. Then, when you try and undo, it says, undo iterpolation change and you ahve to undo for as many layers as there are in the timeline. 

 

First time this has happend in the past 20 years of doing this. It's messing up my workflow, big time. SUPER ANNOYING

 

Dustin 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 26, 2023 Oct 26, 2023

Copy link to clipboard

Copied

Hi Dustin!

Really sorry you hit this bug, but the deselection bug been fixed in 24.0.1 which should be available in Creative Cloud for you to update to! This also takes care of the multiple-undos.

Status Fixed

Votes

Translate

Translate

Report

Report
New Here ,
Oct 26, 2023 Oct 26, 2023

Copy link to clipboard

Copied

Ok thanks! 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 26, 2023 Oct 26, 2023

Copy link to clipboard

Copied

Hi all,

 

This issue has been fixed in the After Effects version 24.0.1. Update your After Effects if it's not already.

Let us know if you experience the issue in 24.0.1.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

This issue has been fixed in After Effects 24.0.1 and later. If you continue to experience this bug, please let us know.

 

- John, After Effects Engineering Team 

Status Fixed

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

LATEST

Marking issue as Fixed in 24.0.1, per @jenkmeister's comment 

Status Fixed

Votes

Translate

Translate

Report

Report