• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Rotation resets to 0 after one lap

Contributor ,
Aug 26, 2023 Aug 26, 2023

Copy link to clipboard

Copied

When using the rotation tool (W) to rotate a layer, after completing a full lap (360deg) the value resets to 0 instead of 1x+0.0

Once the rotation surpasses 360deg, the value snaps back to 1 lap plus however many degrees rotated.

I encountered it after trying to rotate a layer 360 degrees over time. Since the value resets back to zero no extra keyframe is being set.

 

Bug Fixed
TOPICS
Troubleshooting

Views

204

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , May 14, 2024 May 14, 2024

Hi @zsaaro,

This issue with the Rotation tool was fixed in the 24.2 version of After Effects, released in February. Please let us know if you continue to experience this bug in version 24.2 or later.

 

Thanks again for reporting this,

- John, After Effects Engineering Team 

Status Fixed

Votes

Translate

Translate
5 Comments
LEGEND ,
Aug 26, 2023 Aug 26, 2023

Copy link to clipboard

Copied

Your stopwatch isn't even eanbled, so I'm not sure what you expect to happen here. Seems you have a misunderstanding here.

 

Mylenium

Votes

Translate

Translate

Report

Report
Contributor ,
Aug 27, 2023 Aug 27, 2023

Copy link to clipboard

Copied

Simply put, my expectation when spinning a layer 360 degrees in the viewer is to spin it 360 degrees, and not to reset the layer's rotation to where it was.

 

You are correct that my stopwatch wasn't enabled in the video,

that's why I described in the body of my post that even when the stopwatch is on, a new keyframe is not being set, as a result of Ae resetting the value to 0.

 

 

 

 

 

Votes

Translate

Translate

Report

Report
Contributor ,
Aug 27, 2023 Aug 27, 2023

Copy link to clipboard

Copied

Update - this seems to only happen when holding shift while rotation with the Rotation tool

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Sep 05, 2023 Sep 05, 2023

Copy link to clipboard

Copied

Hi @zsaaro,

Thank you for reporting this issue. We've been able to reproduce it as well and will be investigating a fix for a future version of AE.

 

Thanks again,

- John, After Effects Engineering Team 

Status Investigating

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 14, 2024 May 14, 2024

Copy link to clipboard

Copied

LATEST

Hi @zsaaro,

This issue with the Rotation tool was fixed in the 24.2 version of After Effects, released in February. Please let us know if you continue to experience this bug in version 24.2 or later.

 

Thanks again for reporting this,

- John, After Effects Engineering Team 

Status Fixed

Votes

Translate

Translate

Report

Report