• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Running CEP Extensions at above 30fps on MacOS

1 Vote
Contributor ,
Oct 10, 2022 Oct 10, 2022

Copy link to clipboard

Copied

I have noticed that on MacOS, despite my best attempts, the rendering of any extension panel seems to be capped at 30fps.

My best attempt to fix the issue was adding these to my manifest:

  <Parameter>--windowless-frame-rate=60</Parameter>
  <Parameter>--disable-frame-rate-limit</Parameter>
  <Parameter>--disable-gpu-vsync</Parameter>
  <Parameter>--disable-gpu</Parameter>
  <Parameter>--disable-gpu-compositing</Parameter>
  <Parameter>--hardware-acceleration=false</Parameter>
  <Parameter>--hardware-video-decode-framerate=0</Parameter>
  <Parameter>--enable-begin-frame-scheduling</Parameter>

It unlocks a higher fps, but some interactions can feel out of sync from time to time, so I wouldn't want to rely on this when releasing my extension.

 

Does anyone have a better idea?

Thanks 

Bug Acknowledged
TOPICS
Performance , Scripting , SDK , Troubleshooting , UI and UX

Views

76

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Oct 17, 2022 Oct 17, 2022

Hi @zsaaro,

Thank you for reporting this issue. It appears to be a general issue with CEP panels and not specific to After Effects, so we have let the CEP team know about it. They are aware of it and are looking to improve this in future versions of the CEP framework.

 

Thanks again for the report,

- John, After Effects Engineering Team 

Status Acknowledged

Votes

Translate

Translate
1 Comment
Adobe Employee ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

LATEST

Hi @zsaaro,

Thank you for reporting this issue. It appears to be a general issue with CEP panels and not specific to After Effects, so we have let the CEP team know about it. They are aware of it and are looking to improve this in future versions of the CEP framework.

 

Thanks again for the report,

- John, After Effects Engineering Team 

Status Acknowledged

Votes

Translate

Translate

Report

Report