Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


AE Blending Mode "Screen" causes render error in AME

Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

My After Effects project uses a particle flare footage layer with blending mode "Screen".  This plays and looks correct in the AE preview.  However, when exporting to Adobe Media Encoder, it generates a render error.

 

Export Error
Error compiling movie.

Render Error

Render returned error.

Writing with exporter: H.264
Writing to file: \\?\C:\Users\brown\Documents\Adobe\After Effects 2020\Projects\NL\NL_AME\NL.mp4
Writing file type: H264
Around timecode: 00:00:01:00
Rendering at offset: 0.000 seconds
Component: H.264 of type Exporter
Selector: 9
Error code: -1609629695

 

I have found that changing the layer blend mode to others such as Normal, Add, Lighten all work correctly (every other mode I tried except Screen seems to work).

 

Further, I exported the project (using Collect Files), copied it to another PC, where it renders correctly

 

What can I do to fix the AME error?

 

TOPICS
Error or problem, Import and export

Views

243

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jun 09, 2021 Jun 09, 2021
Thanks again for the response. I've tried converting the problematic layer source to a few formats, but no luck.  At this point, I've decided to move AE/AME to my other computer and do the work there. 

Likes

Translate

Translate
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Can you please share your system info? Like OS and version, CPU, RAM, GPU vRAM, Pr version? Thanks. Also a screen grab of your issue will be helpful.

Quick question what are the h264 settings you are using? Does the error also happens when you export to an other format, like Quicktime ProRes?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

AME version 15.2 build 30

AE version 18.2.0 build 37

Windows 10 Pro (version 2004, build 19041.985)

AMD Ryzen 5 2600

16GB RAM

GPU: NVIDIA GeForce GT710

(admittedly a very minimal graphics card, but it's worked fine for everything else I've done so far)

 

I normally use the H264 Youtube 1080p preset, which is what you see here. 

I've also tried Quicktime with the Apple ProRes 422 which also fails.  All the other Quicktime presets I've tried failed, except for the NTSC options which seem to work (but of course at lower resolution).  I can tell which ones will work or not by looking at the preview - the ones which fail to render also fail to preview (it gets stuck at the "Rendering..." in the preview window).

 

uncleranny_1-1623102503260.png

 

 

uncleranny_0-1623100954568.png

 

However, I can successfully render directly from After Effects (not AME) using QuickTime with Best Settings.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

You answered your own question: Turn off GPU acceleration. Screen uses non-inear math which apparently cannot be accommodated in one computing cycle on your slightly older card in conjunction with other GPU accelerated functions such as H.264 encoding. Other than that you can always spend hours trying to figure out driver settings, installing different drivers and the usual, but in your case it's doubtful that this will actually resolve much. It may fix the rendering issue, but introduce another problem due the same resource shortage cropping up in a different place then...

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Thanks for the response.  Where do I set that?  Is it in the AE settings or in the AME settings?  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

I've disabled hardware/GPU in every place I can find.  It still fails with the error.

 

In the AME export settings under Video:

uncleranny_0-1623196815442.png

In the AME queue window:

uncleranny_1-1623196872900.png

In the AME Preferences -> Media -> H264 settings:

uncleranny_2-1623196978743.png

 

In AE Preferences->Display:

uncleranny_3-1623197084417.png

 

In AE Preferences->Import

uncleranny_4-1623197148341.png

 

Is there somewhere else I'm missing?  Any feedback appreciated!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

Fair enough. In this case double-check your sources. Oddly enough AE will still use hardware-accelerated decoding and that may and even when switching to software-only rendering GPU functions are never fully disabled. As a test try to substitute the sources with a different format and/ or setting a proxy and enabling its usage in the render settings. Maybe this will solve this problem.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

LATEST

Thanks again for the response. I've tried converting the problematic layer source to a few formats, but no luck.  At this point, I've decided to move AE/AME to my other computer and do the work there. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines