AE freezes temporarily after Preview

Community Beginner ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

Preview works as expected, it caches the timeline and then plays back in real-time. However, after I stop previewing, AE freezes for about 10-60 seconds (it seems to be linked to how complex the comp was). The mouse starts spinning, and if I click on AE it goes to Not Responding. After a period of time, it goes back to normal and I can resume work.

 

I'm finally driven to writing this because the comp I'm working on currently takes about 3-5 minutes to unfreeze AE. So I need a coffee break after every preview - it's really breaking my workflow. I've been experiencing this issue for about 2 years. I believe it started after one of these things; upgrading to CC 2020, upgrading PC to i9-10900K, upgrading GPU to RTX 3070.

 

Primary things I've tried:

Complete Windows reformat.
I just switched cards from a 3070 to a 3080
My Nvidia Studio Drivers are up to date
My CC apps are the most current version
My system drivers are current, including the latest drivers for my motherboard.

 

System:
Windows 10 x64
i9-10900K
RTX 3080
64GB RAM

 

I'll post any other system specs or information if people need to dig deeper.

TOPICS
Error or problem , Freeze or hang , Preview

Views

86

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

well, at least for the latest versions it could be related to multiframe rendering and cahce consolidation - AE taking too long to shut down the extra render instances. Otherwise I'd strongly suspect a configuration issue with the RTX cards and the display buffers being shuffled around, which of course leaves you with the annoying task of experimenting with the settings in teh NVidia drivers until something works. Outside that there's not much one can say. This is clearly a case where you need to move on to the nerd level and use a tool like Sysinternals' Process Explorer to monitor the various function calls from the program and see which one(s) cause(s) the delay(s) or at least spend some time watching task manager and resource monitor until you see a pattern. This mustn't even be AE, it could be some shietty little driver or tool you are not even aware of...

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 14, 2022 Apr 14, 2022

Copy link to clipboard

Copied

Hi kevinharvey,

 

Sorry for your issue.

Are you on a dual monitor setup? Are you using any third-party plug-in that could cause this or font? Are you using any other GPU-intensive program while using After Effects?

Let us know.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 14, 2022 Apr 14, 2022

Copy link to clipboard

Copied

Good questions. I am using a dual monitor setup however my AE is just using one monitor it doesn't span across both.

Sometimes I have Premiere open also. But generally no other intensive programs. This is also a fresh install of windows so it's pretty lean still. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

Thanks for getting back. How your secondary monitor is connected to your computer? Can you try using After Effects after disconnecting the secondary monitor from the computer? Do you have Mercury Transmit enabled? If so, try disabling it. Also, what's the version of your GPU driver that's installed? 

Let us know.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

Hi Nishu,

 

I appreciate the help. I'm not using Mercury Transmit. AE is only on my main monitor and my side monitor I just keep emails and stuff open on. I did try unplugging it regardless - and I'm still getting the issue. 

 

My video driver is NVIDIA Studio Driver 512.15

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 19, 2022 Apr 19, 2022

Copy link to clipboard

Copied

LATEST

Please try this.

  1. Go to Edit > Preferences > Display > uncheck Hardware Accelerated Composition, Layer, and Footage Panels.
  2. Go to File > Project Settings > change the renderer to Mercury Software Only.
  3. Clear media cache.
  4. Restart After Effects and test the Performane.

Let us know how it goes.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 14, 2022 Apr 14, 2022

Copy link to clipboard

Copied

Would you trun off the setting of Enable Multi-Frame Rendering and try the preview?

 

Edit menu > Preferences > Memory & Performance > Performance section

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 14, 2022 Apr 14, 2022

Copy link to clipboard

Copied

Ah, I should have mentioned this in my main post. I did try this and saw no effect. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 18, 2022 Apr 18, 2022

Copy link to clipboard

Copied

I believe I solved it! 

I had my After Effects cache syncing to a hard drive but it was 7200rpm HDD. I've never noticed anything in the past and I always thought that would be fine. But it looks like that is what was causing the delay. It's possible the drive is going bad or something too. I switched the cache location to a SSD and now it's much better! I've sinced ordered a NVMe that will be a dedicated cache drive. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines