AE will only playback a few seconds

Enthusiast ,
Nov 29, 2016 Nov 29, 2016

Copy link to clipboard

Copied

AE will only playback a few seconds of the work and then goes back and plays the same thing over and over again. The playhead does not move. I am not very familiar with AE so I was doing one of the lessons and I cannot get a playback on a 15 second bit. What gives?

Views

31.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Nov 16, 2021 Nov 16, 2021

I suggest to try in the "Preview" Panel (Window>> Preview; usually CTRL+3 shortcut)
Select in the dropdown menu "spacebar" >> set range "play around current time" - In the pop-up window select "preroll to 2 seconds Postroll to 45 seconds"
"Play from" to  Current Time.
You'll have 45 seconds of preview if you need more preview time try to add seconds to "postroll".
I have a same issue with lates Ver. 22 update.
IMHO, I believe that Adobe should sit down and rewrite the whole Code of App from scratch,

...

Likes

Translate

Translate
LEGEND ,
Nov 29, 2016 Nov 29, 2016

Copy link to clipboard

Copied

what is your exact Os version? exact computer hardware? what exact Ae version? what have you got in your setup? show us screenshots. bare in mind that Ae is designed to give real-time playback of cached frames. it could be that you are running low on available RAM and Ae gives you what it can cache to memory.

more about preview here: Preview without rendering in After Effects

here's a video for you: Uninterrupted and simplified preview in After Effects

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 29, 2016 Nov 29, 2016

Copy link to clipboard

Copied

Screen Shot 2016-11-29 at 4.45.27 PM.pngScreen Shot 2016-11-29 at 4.52.33 PM.pngScreen Shot 2016-11-29 at 5.00.08 PM.png

I should have plenty of room. If you look on the photo of AE opened you can see the scene I am working on is the tutorial about the spaceship. If you look in the little red line in the timeline you can see that it goes only to 5 seconds (each time the distance varies - this was longer then most). It then loops back over that 'green' area - over and over again, so I never see the completed work.

I am using the Essentials format. And, Yes, I have seen both those tutorials but they don't quite hit the nail on the head for this concern.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 29, 2016 Nov 29, 2016

Copy link to clipboard

Copied

Oooh, I see you have only 4 GB RAM.  That's barely enough to run the OS and After Effects at the same time.  I'm not surprised your previews are so short.

You need to procure more memory, ma'am.  16GB is a good amount.  Don't blanch at the number; many users have 32 or 64 GB.  But 16 does the trick without breaking the bank.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 29, 2016 Nov 29, 2016

Copy link to clipboard

Copied

this is your problem

your system has a very low RAM. this means less room for caching frames. these are the system requirements

After Effects System Requirements for Mac OS and Windows

you are below recommended level so don't expect too much of a performance with your machine.

there are ways to get by. lowering the resolution pop up menu and other things. read all about them here:

Improve performance in After Effects

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 27, 2019 Nov 27, 2019

Copy link to clipboard

Copied

I am having the same problem and I have 16 gb ram. Is it normal with my settings?Capture.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 27, 2020 Jul 27, 2020

Copy link to clipboard

Copied

Same for me? You find out any solution? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 22, 2020 Sep 22, 2020

Copy link to clipboard

Copied

Same. Need help. Can't get more than 2 seconds.

I have 64GBs of Ram, lol.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 22, 2020 Sep 22, 2020

Copy link to clipboard

Copied

If you have 64 GB of RAM and your comp is a normal HD or 4K comp, I would expect you to be able to get more than two seconds of your composition cached.

Is your work area set to your full composition?

How many layers are in your comp?

What are your AE memory preferences settings?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 06, 2018 Jul 06, 2018

Copy link to clipboard

Copied

Mine is 12 GB ram and a average graphic card windows 10 i3 core still my previews are short

(50 seconds render out of a 6 min clip

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 06, 2018 Jul 06, 2018

Copy link to clipboard

Copied

vfx_noob  wrote

Mine is 12 GB ram...50 seconds render out of a 6 min clip

Sounds about right.  AE IS NOT DESIGNED to play video like an editing application can.  So get used to it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 27, 2021 Mar 27, 2021

Copy link to clipboard

Copied

Im just going to say that I have found your replies to be arrogant and dismissive. How can someone accept that they are unable to preview an animation? You NEED TO BE ABLE TO PREVIEW YOUR WORK. I would say that Adobe Creative cloud from my experience, is fine polishing the flaws to give an impression that CC is just the best. I spent hours trying to add bones to a character in Animate, and it just glitched. I then went on to my ancient MAC opened up CrazyTalk animator and managed to add bones to my character in a matter of minutes. I am also able to replay quite complex sequences on CrazyTalk, and After Effects cannot replay a 20 second masking effect. There is a great modelling programme in CC - Dimension - yet you cant use it to make 3d props for an animation programme. And I ask why Blender is able to work totally fine on my pc and yet its a task on CC? And the fact that you either have to pay for all the apps or just the photography app as an option. Photoshop is the one most efficient and workiing programme on CC - its the only one that actually lives up to its reputation...

I think if you wish to help people solve their 'CC' problems, telling themn that their computers aren't up to it or they just dont have a clue is not very helpful, some compassion and acknowledgement that CC is not perfect and putting forward helpful suggestions would be a lot more supportive

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2021 Apr 13, 2021

Copy link to clipboard

Copied

Just apply more RAM to the program. Your probably not allocating what you have in the system. Open up After Effects. Go into your AE Preferences. Click on After Effects > Preferences > Memory & Multiprocessing. Change 'RAM for Other Applications'Click 'Ok' And you're done! You should see an increase in your preview time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 06, 2018 Jul 06, 2018

Copy link to clipboard

Copied

With that amount of RAM, thanks After Effects opens because surely your entire system is slow. I recommend you upload the RAM everything your pocket supports.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2021 Aug 25, 2021

Copy link to clipboard

Copied

Hi Guys,

 

I come across the same exact issue while making some animations. This post did not help very much and i think you guys are bloawing this out of proportion recommending to update hardware etc.

 

Here is the solution

 

Once you have AE running

>

Click Edit>Preferences>Memory

>

Assign after effects program more of your RAM and clear your cache to fix the issue.

 

You can now preview all of your timeline without limitation. 

 

Kudos People!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 19, 2021 Oct 19, 2021

Copy link to clipboard

Copied

Hey guys! I have this problem to - and it just recently started! i amade clips before, never this problem. i have 16 GB ram, 13 is given to After Effects. i am doing a VERY simple animation - just an Illustrator file moving forward and some letters. Yet it can preview only 5 seconds. i have a deadline in one and a half day and it's driving me nuts! i am at the very beginning of a 4 minute clip with 33 PNGs to move. I dont get any further!

Screenshot 2021-10-19 at 23.46.15.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 19, 2021 Oct 19, 2021

Copy link to clipboard

Copied

Hello Martin, 

 

Here is the solution

 

Once you have AE running

>

Click Edit>Preferences>Memory

>

Assign after effects program more of your RAM and clear your cache to fix the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 19, 2021 Oct 19, 2021

Copy link to clipboard

Copied

If you have 16 GB of RAM with 13 assigned to AE, I would NOT recommend assigning more. AE utilizes processes outside of itself, as does your computer - and you do NOT want to starve your system of RAM. Generally, I'd recommend 12 to AE in your situation.

That said, you don't need to preview from the beginning of your comp every time and you don't need to preview at full resolution either. Crank that resolution down as far as you can and still preview the motion as needed. And utilize the work area to only preview the necessary parts.

Also, my suspicion is that these PNG files may be much larger than they need to be and that is what's taking up so much of your RAM. Resize them in Photoshop down to the smallest size you can get away with (smallest amount of pixels wide, not smallest file size, mind you) and try that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

Hey Chris and Szalam! Thank you for reaching out...

As Szalam said, i can' give more memory to After Effects, but i have made two far more complicated videoclips in after effect than this - with this version, on this system.

De PNG files are indeed larger than framewith, because i need to move them around: the come from outside the frame and we pan across it. But i did not get as far as that. I will of course keep in mind what you say. Szalam - very good tip about the pixels being more important than the file size (i made everything as small as possible, but I might need to make them smaller qua pixels) 

 

But the thing is: i am not there yet in the project. The files are in the project but later on the timeline. I expect After Effects to render only de selected part as I work in focus parts, as reccomended. So i want to prerender and preview only the one image (that is not too big) and very simply animated type. The heavy part would be still to come!

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

to test my point, i threw away the PNG files (mind you, there was no animation in that yet, even) but After Effects still can show me a few seconds and, worse: it needs to recalculate every time i try to preview without having made any change. I am about to give up: how am i going to make a deadline here? It wasn't like this before...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

For those who are interested: 

• i actually decreased memory given to After Effects, contrary to what you read everywhere on the internet. Apparantly my system needs more than i gave it.
• i started anew; i wanted to be sure if it wasn;t somehow a corrupte document that i was working with. 

 

So far, that worked (a bit, but i am still worried): I just made a new simple text animation and position change with one image, fitting to the music. (see screenshot)

I can work, and it is showing me more than a few seconds. But I am worried because as you can see on the green line in the screenshot: it has already troubles prerendering this very simple thing. i am afraid i get into problems importing anything of my material. 

Yes, i did P-RAM too, a few times...

 

It's hard for me to understand I could make this clip: https://www.youtube.com/watch?v=RTJjSI_61fo without too much problems and now it does not allow me to do a few titles and PNGs?

 

This is the videoclip for my third single, called 'Multiple Reality Disorder'. Laura A Dima and I develop a Instagram Soap Opera with the title 'The Identity...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

This is an old fix, which might not be applicable, but it's worth a shot.  I see your comp has an MP3 audio file.  IO take it you're trying to play that back at the same time.  I was told years ago that the trouble with MP3s in AE is that AE has to uncompress them first to play. It might be worth trying rendering out a WAV version of the audio and see if that helps.

Second suggestion, I've noticed that as my media cache fills up, previews take longer and longer to get started and sometimes I get shorter previews too.  Have you tried clearing the cache? 

 

I take it there's no network drives involved?  All the files are local to you computer.  Are your graphics card drivers up to date and are you using them or is it software only? (File > Project Settings)

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 20, 2021 Oct 20, 2021

Copy link to clipboard

Copied

hey ShiveringCactus!

Thank you for the suggestions. I vaguely remembered something like you said and changed the MP3 for a wav. The only difference is, that it is audible every time i preview where as the MP3 was only half the times. So we are getting there, step by step 😉

 

I purged, emptied my chaches by hand, started up with P-RAM. But anyway, this is a very new document with not many files in there, it really is not complicated at all. And it's new, so I could not pile up much.

 

I don't work with network drives other than an ssd that hosts my png images: after effects is on the desktop. I have 70 gieg of cache room, completely free. I understand i cannot edit many explostions in a cinema movie, but a new 1k document with some titles should work?

 

update: the problem returned in it's full state, eventhough the MP3 is now a WAV, the PNGs are smaller etc. After Effects sometimes drives me crazy. It is like they give you a program that can do anything you like - in theory only.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 16, 2021 Nov 16, 2021

Copy link to clipboard

Copied

I suggest to try in the "Preview" Panel (Window>> Preview; usually CTRL+3 shortcut)
Select in the dropdown menu "spacebar" >> set range "play around current time" - In the pop-up window select "preroll to 2 seconds Postroll to 45 seconds"
"Play from" to  Current Time.
You'll have 45 seconds of preview if you need more preview time try to add seconds to "postroll".
I have a same issue with lates Ver. 22 update.
IMHO, I believe that Adobe should sit down and rewrite the whole Code of App from scratch, they just fixing a few decades old code which in the end will not keep-up with the technology.
Great all around software but awfully low preview capabilites.
Good luck!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Amazing Stojan! This actually works! Thank you very much! If i ask for a postroll of 300 seconsd it does so withouth problem.! Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines