• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

After Effect running slow on m1 pro 2021

Community Beginner ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

Hi, I just want to know I recently shift to MacBook and I have Mac M1 Pro 2021. I used adobe premiere pro and it works perfectly either timeline or renders but today I work on video and use after Effects and that makes me shocked because after effect is very slow and the timeline takes so long to load. 

I do change my render to CPU which is mac built-in but still very low, can someone please guide me what's wrong with that because I wasn't expected such performance.

TOPICS
Expressions , FAQ , Performance , Preview

Views

1.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Apr 12, 2022 Apr 12, 2022

Also, because you are using an Apple Silicon M1 Pro Mac, make sure you updated to the After Effects 22.3 update which came out yesterday. It’s the first Apple Silicon native release, so performance should be far superior to running the Intel version on an M1 Mac.

Likes

Translate

Translate
Adobe Employee ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

Hi Awais Butt,

 

Welcome to the community.

Is it the After Effects interface or playback that's slow (could you share a screen recording)? What are the details of the footage you imported (frame rate, frame size, format/codec)? Also, does it happen in all the projects?

Let us know, we're here to help.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 12, 2022 Apr 12, 2022

Copy link to clipboard

Copied

Well, it's playback, I mean when I click on render preview it's load slow but other actions are going well.
Also I just started project on new device so I will check more work soon but for testing I used to upload new project and it's also play slow then I let me render preview 1/2 

Thanks for your support 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 12, 2022 Apr 12, 2022

Copy link to clipboard

Copied

Also, because you are using an Apple Silicon M1 Pro Mac, make sure you updated to the After Effects 22.3 update which came out yesterday. It’s the first Apple Silicon native release, so performance should be far superior to running the Intel version on an M1 Mac.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 13, 2022 Apr 13, 2022

Copy link to clipboard

Copied

Ok, I will update soon and hopefully, it will fix 🙂
Thanks for the help 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2022 Oct 15, 2022

Copy link to clipboard

Copied

I am having similar issues on my 2014 M1 Pro. I have the 10-core model with 32GB RAM, and the performance is nearly unusable. Using AE v22.6, a 10-second fairly basic timeline that is taking over 2 hours to render (the same project on a colleague's PC takes ~5 minutes). Activity Monitor shows little use, and the battery is hardly draining. Editing text on a soloed layer within the comp has 2-5 second delays. Any acknowledgement or suggestions would be welcome. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

I'm observing the same problem. Use a Macbook Pro 2021 M1 Pro with 32 GB RAM. Work with Adobe Character, Illustrator and After Effects, using Dynamic Link. Both playback and rendering take a very, very long time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

Edit: *2021 M1 Pro. 
All of their Adobe apps run fast and responsive, Premiere has had no issues at all. The slow rendering issue seems to be only in AE. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2022 Oct 18, 2022

Copy link to clipboard

Copied

True. Even Adobe Character runs smoothly. It's only AE, also when used without embedded Dynamic Link files from character. Does anyone have asolution for that issue? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 12, 2023 Jan 12, 2023

Copy link to clipboard

Copied

I find After Effects runs very fast and normally for a while, then starts to slow down suddenly. I restart it and it goes back to being fast for a while. It's like the M1 allocates memory away from it and hobbles it... anyone else notice this pattern?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2023 Jan 16, 2023

Copy link to clipboard

Copied

LATEST

Yes. This is exactly what is happening.  It starts very fast renders are like a breeze in the beginneing then suddenly it goes dead in terms of speedm i restart it again gets fast for sometime. Not able to figure out the prob/solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines