• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

After Effects 2023 Rotobrush not working

Explorer ,
Aug 07, 2023 Aug 07, 2023

Copy link to clipboard

Copied

Hi,

 

I can't add or reduce the selection area. Even using the Refine Edge tool. It works at first... I am surprised no one else has had this problem... 

 

The situation - I am trying to rotoscope a hand as it passes over a screen. Halfway through some of the  fingers disappear. I don't want this, so I try to extend the mask. This shows up as I did do something... it makes a foreground selection but this doesn't effect anything. It doesn't do anything.

 

Refine Edge helped a little but it is the same problem after the initial frames. I can't refiine anything. This isn't like the fingers are motion blur... They aren't moving fast. I just can't correct the selection. 

 

I am going to try this with a previous version but I already did all the rest of the work on the project so I will have to redo it all in a different version? Ugh.

 

 

TOPICS
Performance

Views

268

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 08, 2023 Aug 08, 2023

Copy link to clipboard

Copied

I’m sorry you’re having trouble adding correction strokes to the selection area. 

If possible, please provide a screen recording of your workflow. After viewing session, I might have some suggestions on how to resolve issue. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 09, 2023 Aug 09, 2023

Copy link to clipboard

Copied

Per @James Landy's response, marking as Needs More Info.

- John, After Effects Engineering Team   

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 11, 2023 Aug 11, 2023

Copy link to clipboard

Copied

a screen recording? I can if you really want, but I am not doing anything special.

 

 I can just explain it. It's really not that difficult. You are correct, correcting strokes are not showing.

 

It's really simple. I start in Premiere > Right click on the clip > Replace with After Effects Composition >

Now I am in After Effects. 

Double Click on video, select Rotoscope brush, drag the first stroke in the middle of the object, and the first stroke is fine. I don't need to correct for a few frames... Any corrections added after the first frame seems to add a Foreground stroke, but it does not register or effect the selection. The first selection is fine. That shows up but anything else does not. I have even tried to remake this project twice using the same steps. (there are the same clips where I tracked some screens and put a different video in it but that should not effect the layer as they are different layers).

 

 

My solution - 

Instead I just used a mask for the frames that didn't work. 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 11, 2023 Aug 11, 2023

Copy link to clipboard

Copied

I'm sorry, what more information do you need? I don't think I need a recording session for this. This is pretty straightforward. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 14, 2023 Aug 14, 2023

Copy link to clipboard

Copied

The reason I’m requesting a screen recording is because I can’t reproduce what your describing in-house, and I’m not aware of any other users encountering the problem you're experiencing.  Watching a screen recording will help to determine if this is a user error or a bug.   

Please also provide what version of Ae your using along with system and hardware specs. And please let us know if issue occurs without using Dynamic Link in your workflow (i.e., Replace with Ae comp).

Thanks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 20, 2023 Dec 20, 2023

Copy link to clipboard

Copied

@James Landy - So... it doesn't always do this but since upgrading to Rotobrush 2 it has been doing this more where I can't edit the brush strokes. Whatever. I am just going to have to live with it probably and just use masks in the footage that it doesn't work. There are several scenes where I am not time ramping or using any effects or anything like that, some scenes I can edit the brush strokes... some I can't for the same footage (but at different spots).  I am really surprised that this isn't something more people complain about. It doesn't always happen... like it seems like the first few brush strokes seem to do the job most of the time but sometimes it doesn't and I can't fix it (like it misses a finger or half of the hand and I can't add it back no matter how many times I go back over it).

I don't know how to post video clips. Do I screen record and then put it on youtube and then post the link here? Next time it happens I can record it. Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 03, 2024 Apr 03, 2024

Copy link to clipboard

Copied

LATEST

Sorry for the delayed response. Can you try the new version and see if you're still having issue with Roto Brush?

We're here to help. Moving this thread from Bugs to Discussions for troubleshooting.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines