After Effects not releasing memory after RAM render.

New Here ,
Sep 30, 2017 Sep 30, 2017

Copy link to clipboard

Copied

Hello,

This is my first post so forgive me if I forget to include some information.  My specs are

OS: Win 10

CPU: Intel i5 7600k

MB: MSI z270-A Pro

RAM: 16gb DDR4

GPU: GTX 750ti

SSD: 1tb

The problem I am having is when I do a RAM preview render AE has been crashing.  I opened up task manager to see if it is a RAM thing and it seems to be.  As it approaches the limit set for AE (in the preferences menu: 6gb) it crashes.  Setting the limit higher (10gb) does nothing much better and this is why...  When I preview, I watch the RAM usage creep up in task manager and it goes up quick.  When I am done previewing, the usage stays at that same level even when I adjust something in my project (which I assume would release what was in memory so it can do a new preview).  The clip I am rendering is not very long (15 seconds max and really it crashes at about 5 seconds of render) and only uses 2 instances of Trapcode Particular.

To rephrase after a long winded explanation:  I can RAM preview but each subsequent preview adds to the memory usages of my allowable RAM.  For example, if I have 10gb of RAM allocated to AE and I preview something that takes up 50% of that amount and I need to adjust something, the next preview adds to that 50% so if I preview the same amount again, I run out of RAM and AE crashes.  Is this normal and am I making any sense?

Thanks for any advice.

Adam Raitano

Views

2.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Oct 01, 2017 Oct 01, 2017
I had this annoying problems too. I can't RAM preview although I have dedicated almost all RAM for preview. My workaround is, clear the cache Edit>Purge>All Memory & Cache. Sometimes I have to restart AE 2017. Hope this helps?

Likes

Translate

Translate
Adobe Community Professional ,
Oct 01, 2017 Oct 01, 2017

Copy link to clipboard

Copied

This is not normal, but without seeing any hard evidence in the form of crash logs and possible the dumps to debug the memory addresses nobody can tell you much. This is definitely some memory leak and the bad news is that it could even be some system driver and may have nothing to do with the plug-ins or AE for that matter.

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 01, 2017 Oct 01, 2017

Copy link to clipboard

Copied

I had this annoying problems too. I can't RAM preview although I have dedicated almost all RAM for preview. My workaround is, clear the cache Edit>Purge>All Memory & Cache. Sometimes I have to restart AE 2017. Hope this helps?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 10, 2017 Oct 10, 2017

Copy link to clipboard

Copied

Hi A. Raitano, Did you try what Hussin suggested?

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 12, 2018 Feb 12, 2018

Copy link to clipboard

Copied

While this solution does work it is not an intuitive way to clear RAM usage. I'm currently working with several small objects that I'm trying to animate and I find my usage jumping up to my max (12GB) after animating 1-2 small objects. I've also experienced a similar issue with Photoshop when I am working with around 15-20 smart objects. My RAM usage jumps up to my limit and both of my screens go black and I am forced to power my desktop off manually.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 06, 2017 Nov 06, 2017

Copy link to clipboard

Copied

Sorry, I've been away from that project for a while and haven't had to deal with that issue.  Since then, not really any issues involving that problem that a disk cache purge can't fix.  Thanks for the help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 09, 2017 Nov 09, 2017

Copy link to clipboard

Copied

I've been having a very similar issue. For me, when rendering multiple comps in a render queue, AE won't clear memory between renders, so it keeps on sucking up memory until my computer freezes with a 'Out of System RAM' dialogue box.

It makes it nearly impossible to queue up projects of any kind of complexity.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 06, 2021 Sep 06, 2021

Copy link to clipboard

Copied

it is 2021! and I googled as i run in the same issue. 

 

Just opened a non-fancy animation of 2 minutes to export and after thats has been processed, the RAM is still full while nothing is processed in the Background. 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 19, 2021 Sep 19, 2021

Copy link to clipboard

Copied

Yes, I have the same errors in AE 2021. Actually I get to the point that I even have to reinstall VGA drivers, because my 4K resolution environment is switched back to very low resolution due to low memory.
Never had these terrible issues before with After Effects CS6.

 

Seriously, what the f**k Adobe does? An app in subscription model at this level of quality? Really no component, regression, etc testing? This is beta quality, NOT production!

 

Isn't there a solution architect or better developers to properly maintain this memory hog application?

 

Adobe could pay the best devs, as After Effects is getting more and more awkward with every new release!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 08, 2021 Dec 08, 2021

Copy link to clipboard

Copied

LATEST

I completely agree. I feel ripped of and really want an alternative to the adobe suite

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines