Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


AI layer files appear black in AE... Does anyone know how to change that?

New Here ,
Jun 03, 2016 Jun 03, 2016

Copy link to clipboard

Copied

Hey Everyone,

So I'm creating an animation in AE, but first I wanted to create a custom logo in Illustrator. It's a simple word and rectangular box outline. I had separated the text as individual shapes so that I could manipulate each one manually in AE. Screen Shot 2016-06-03 at 3.49.20 PM.png

Having separated each shape into its own layer I saved the file. I only used ONE artboard. The background is obviously not black, and it's in RGB colorspace not CMYK. Going into AE I import the file with the following setup:

Screen Shot 2016-06-03 at 3.52.27 PM.png

All layers import. The problem is that they are all black when I open the composition.

Screen Shot 2016-06-03 at 3.56.14 PM.png

If anyone can please answer this question it would be greatly appreciated as I haven't found the correct answer after searching the forums for the last couple hours.

Thanks!

Views

28.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Aug 18, 2017 Aug 18, 2017
I had the same issue and it was fixed once my caps lock was turned off.

Likes

Translate

Translate
Adobe Community Professional ,
Jun 03, 2016 Jun 03, 2016

Copy link to clipboard

Copied

Can you post a screen grab of the timeline and comp preview panes.  Make sure the Illustrator comp is open, and select one of the problem layers and press UU to reveal all non-default property values.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 03, 2016 Jun 03, 2016

Copy link to clipboard

Copied

Was the option for saving PDF information turned on in your Illustrator save dialog?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 03, 2016 Jun 03, 2016

Copy link to clipboard

Copied

Open the Borden Sequence comp, make sure no layers are selected or all layers are selected, press the U key twice to reveal all modified properties of all layers. Enable the transparency grid in the Composition Panel to check for art on your layers. If you see art then you have to check the properties for the layers in Illustrator to see why you are not getting color. If you see no art then you should check the save options in Illustrator.

One more thing to check, select a layer in the Project Panel or the Timeline and then select Edit Original (Ctrl/Cmnd + e) and see what opens in Illustrator.

Let us know what you find. Post screenshots of AE with the Borden Sequence comp open and the modified properties of the layers revealed by simply dragging the screenshot to the reply field on this forum or if you used PntScn on a Windows machine you can just paste (Ctrl/Cmnd + v). Maybe we can figure this out if you don't fix the problem on your own.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 14, 2016 Oct 14, 2016

Copy link to clipboard

Copied

I am having the same issue now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 14, 2016 Oct 14, 2016

Copy link to clipboard

Copied

You can't have more than one artboard in the Ai file. I know what you are thinking. Why I can't have more than one artboard?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 15, 2016 Oct 15, 2016

Copy link to clipboard

Copied

Unfortunately Op never came back so we will never know what was the issue. you should work with the presets (that has 2 Artboards and this is a good thing). even if you are not, make sure you prepare your Ai file prior to importing it to Ae. Preparing and importing still images in After Effects

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 10, 2020 May 10, 2020

Copy link to clipboard

Copied

( CORRECT ANSWER RIGHT HERE ) only 1 artboard for after effects

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 03, 2021 May 03, 2021

Copy link to clipboard

Copied

This was it! I forgot to check for the second artboard

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

It is 2021 and still the same issue. While importing a file into after effect, you should not have more than one Artboard, otherwise, it will be imported as black layers in After effects.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 20, 2021 Mar 20, 2021

Copy link to clipboard

Copied

Hey there,

The reason this was happening to me was because there were raster files within my vector AI file. So the raster images were coming in pure black.

Use Photoshop for raster work and Illustrator for vector work. Hope that helps!

Sent from my iPhone

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 24, 2017 Jan 24, 2017

Copy link to clipboard

Copied

I Was having same prob and Szalam suggestion fixed it for me.
When saving illustrator file make sure "Create PDF Compatible File" is ticked: PDF-Compatible-Tick.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 22, 2017 May 22, 2017

Copy link to clipboard

Copied

Try going to Composition > Preview > Play Current Preview. That seemed to work for me. I had the same problem, hopefully this works out for you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 07, 2017 Aug 07, 2017

Copy link to clipboard

Copied

Hi,
Try  this and if the situation is for you also
Here is it
Check all the active layers are placed in artboard or not, in ai file by opening in illustrator.

if not
select all the elements by marking around the objects using move tool and then drag them to the art board.
Then save it and reimport the newly saved file with your desired comp settings in AE

Have  a nice day!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 18, 2017 Aug 18, 2017

Copy link to clipboard

Copied

I had the same issue and it was fixed once my caps lock was turned off.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 31, 2017 Aug 31, 2017

Copy link to clipboard

Copied

ryana52278096  wrote

I had the same issue and it was fixed once my caps lock was turned off.

Crazy as it might seem, this fixed the issue for me as well. Caps lock on - anything I import to AE was black. Caps lock off, everything imports perfect and is visible.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 13, 2018 Jul 13, 2018

Copy link to clipboard

Copied

For some reason, the Caps Lock solution is not working for me. My Caps Lock has not been on for any point in this process and all of my layers still appear black in AE.

Anyone else find alternative solutions?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 13, 2018 Jul 13, 2018

Copy link to clipboard

Copied

Start by creating a new Illustrator file. Select red for fill and white for stroke and create a rectangle. Create a new layer. Select blue for fill and green for stroke and create another shape. Save the file making sure that PDF compatible file is checked and import as a composition retaining layer size. You should see the artwork in the preview pane of the Project Panel.

If that works, check the original file for differences. If it doesn't work make sure the document settings in AI are RGB and not CMYK. It should not make any difference if your AI and AE are current versions.

If none of that works, your AE and AI are up to date, create a file that does not work for you and share it here and somebody will take a look at it. There is more than a 95% chance that the problem is user error.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 18, 2018 Sep 18, 2018

Copy link to clipboard

Copied

Did you try pressing it? Mine wasn't turned on either but I gave it a try anyway. Turned Caps Lock on then off again, layers showed up. So random

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 07, 2019 Nov 07, 2019

Copy link to clipboard

Copied

Hey guys, I've been suffering from the same problem. it's reall strange. I've made this cool illustration in illustrator, made up all the different parts into layers as needed when transferring to after effects, I imported the file into the software, it works fine, all the files show, but there is nothing on screen.  On about 2 out of 10 times i tried, i could see the some of the images by clicking on them, and they'ed show in the composition screen. anyway, i've been thinking about issues that may cause this, I'm a new guy to after effects so I'm sure its something simple.

 

-Maybe it has to do with update that was just released ?

-I have a bunch of grain effects on the file in illustrator, can that cause any problems?

-I'm saving the original Ai file on google drive, could that be problematic ?

-Maybe it has something to do with the colors ? I checked and my Ai file was set to RGB.

 

TLDR:

Vector images i uploaded to after effects are seen in the project tab, their bounding box are present, but all i see in the composition tab is a black screen. HELP NEEDED!

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 25, 2019 Nov 25, 2019

Copy link to clipboard

Copied

this is happening to me!!! send help 😕 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 25, 2019 Nov 25, 2019

Copy link to clipboard

Copied

Hey! BTW, the situation has been fixed and apparently it was because the illustrator files i was importing into AE, were abnormally huge, like 500 mega bytes. I should have proccessed them through photoshop instead. (Rasterising them) hope this helps !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 04, 2019 Dec 04, 2019

Copy link to clipboard

Copied

Hi there, I think that you should check Artboard in file AI and make sure that only have 1 Artboard in file AI

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2019 Dec 20, 2019

Copy link to clipboard

Copied

Yes ! It worked for me !!! Thanks for sharing 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 08, 2020 May 08, 2020

Copy link to clipboard

Copied

Hi everyone,

 

After digging through many discussions and threads about this very issue, I have miraculously found a solution that has worked for me. Followed all of the suggestions on forums like these, including checking the "Create PDF Compatible File" box in the AI options panel, switching the AI file to RGB mode, turning on the Transparency Grid and reducing the screen resolution to 72 dpi, but alas none of them have been successful. However, after repeated trials of saving and importing, I came across a strange discovery that has lead me to having visible Illustrator Layers in After Effects with no black screen!

 

In my particular case, I found out that After Effects would not showcase AI files that were saved in the latest version of Illustrator. So I saved the Illustrator 2020 file as a legacy one (or Illustator CC) and opened it in an earlier version of AI (Illustrator 2018). I then saved the file in Illustrator 2018 - replacing the one that was saved in Illustrator 2020 - , imported that into AE and - Voila! It worked! Not sure why it did but I can now see the layers when I drag them into the timeline!

 

Just to clear up - I am using the newest version of After Effects (2020) in case you thought I was using an earlier one which does not support newer AI files. Also as a side note, I am not sure whether this solution will work for everybody who is searching all over the web like I was, but I am posting my findings on here anyways to potentially save a life out there!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2