AI layers hiding when hide non parented layer

Participant ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

I have a bunch of AI layers parented to a null and I have a some shapelayers precomped and parented to another null. When I hide the precomp some of my AI layers hide.  I cannot see any reason this would happen. They arent connected in any way. They arent parented, theres no expressions, Ive looked in the precomp to see if anyhting there but nothing. The AI layers had disappeared and I was wondering where they were then I noticed they disappear after the precomp layer ended in the timeline so i went back a bit and they reappeared and then I hit the hide switch and same thing. Ive purged multiple times and restarted but its still happening.  It seems like a bug.

TOPICS
Error or problem

Views

60

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

Also I moved the precomp above the layers in the stack and it hides them all. theres no track matte.  The precomp has a mask on it but it cant be that because the mask has nothing to do with those other layers and I even moved it around to make sure

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

I removed the offending AI layers from the comp. Renamed them in the project panel then put them back in the comp. Once I change them to 3D and move them back in space a bit the issue happens again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

Start troubleshooting by looking for Expressions, Guide Layers, and Effects that reference other layers in any nested comps. The Main Comp Flowchart is a good place to start. If we cannot see your workflow or trace the relationship of one set of layers to others, it's impossible to point to a solution. Embedded, not uploaded screenshots of the Comps with the modified properties of the problem layers revealed (uu) would help us help you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

Ive have looked at it witha  fine tooth comb and even deleted everyhting excpet the precomp and AI layers so that I could make sure it was nothing else. theres no expressions or referencing etc  Not sure how to embed screenshots?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

I copied the precomp and the AI layers to a new comp and the behaviour doesnt happen.  So its something about that other comp that is causing it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

Ok so i figured out what is cuasing the problem.  I have no idea why though.  I have a 3D solid layer in the background and when I switch off the 3D the issue no longer occurs.  The solid is not linked to anything else in any way. Its at the very bottom of the stack just as background. Weird.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 07, 2022 Aug 07, 2022

Copy link to clipboard

Copied

If switching the layer to 3D then you must check its Z Position. If the layer z position is closer to the camera than the other layers then it can "hide" them.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 07, 2022 Aug 07, 2022

Copy link to clipboard

Copied

LATEST

The layer was not closer to the camera. It was the furthest away from the camera as it is the background and it only effected 3 of the other layers. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

Are you using the standard classic 3D renderer or the Cinema 4D renderer. I've seen this behaviour when using the Cinema 4D renderer. Enter into your composition settings (Composition > Composition Settings) and go to 3D Renderer tab.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 06, 2022 Aug 06, 2022

Copy link to clipboard

Copied

I checked and Im using classic 3D

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines