• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

An absolutely absurd problem in After Effects

New Here ,
Jul 28, 2018 Jul 28, 2018

Copy link to clipboard

Copied

So this problem I'm having started out of nowhere. I have not changed anything on my PC/After Effects settings. I am really good with computers and solving these kind of problems, but everything that I've tried has not worked. I have tweaked around with all kinds of different composition settings. I re-recorded the footage like 3 times and the same thing happened each time. I have used both Adobe Premiere Pro and After Effects for a long time and I have never had problems like this. This exact same problem occurs in Adobe Premiere Pro too. The problem is quite simple:

I have a video clip of gameplay footage, which is recorded in 1920x1080 resolution. Full HD 16:9 video clip. You can see a screenshot of the footage here:ingame01.jpg

Proof that the file is indeed 1920x1080:

proof01.PNG

Now importing the file into the After Effects composition (1920x1080 composition), this is what I see:

previewwindow.PNG

As you can see there are black borders around the footage. The software thinks for some reason that the file is 1680x1050, and completely removes the remaining frames that you should be able to see.  Here's what After Effects properties are for the file:

proof02.PNG

Here is a comparison of the actual video from Windows Media Player, and after that the After Effects preview footage.

Windows Media Player:

ingame01.jpg

After Effects:

ingame02.PNG

Also something interesting to notice is that the composition is not cut out from each side of the video, but instead the video is cut the remaining 1920-1680=240 pixels from only the right side. Similarly the video is cut from only the bottom the remaining 1080-1050=30 pixels.

What on earth is going on and how do I fix this?

Views

628

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Jul 28, 2018 Jul 28, 2018

MPEG streams can have a view area that must not match the native resolution. Looks like an issue in your screen capture software with setting those tags wrongly and/ or the Adobe apps using the wrong set of dimension data. You probably will have to fiddle with some setting somewhere. The immediate solution would of course be a quick transcode in an ffmpeg-based encoder.

Mylenium

Votes

Translate

Translate
LEGEND ,
Jul 28, 2018 Jul 28, 2018

Copy link to clipboard

Copied

MPEG streams can have a view area that must not match the native resolution. Looks like an issue in your screen capture software with setting those tags wrongly and/ or the Adobe apps using the wrong set of dimension data. You probably will have to fiddle with some setting somewhere. The immediate solution would of course be a quick transcode in an ffmpeg-based encoder.

Mylenium

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2018 Jul 28, 2018

Copy link to clipboard

Copied

Thank you for the quick answer.

Alright so I tweaked around with alot of stuff for a long time and actually managed to solve the problem. So you were pretty much correct, the problem was my recording program. I use NVIDIA Shadowplay to record everything. And for some reason it simply freaked out and corrupted the files properties in some way to display them in adobe after effects as 1680x1050 footage instead of 1920x1080, which Windows did display them as.

I backtracked alot of versions in Geforce Experience (The program that you get NVIDIA Shadowplay with) to a version from like 8 months ago. Then I tried to record everything in the all too familiar way, to notice that now the captured footage is indeed displayed as 1920x1080 in After Effects.

So for everyone wondering about this really absurd and random problem which definitely not too many will ever face, the recording program should be the first lead to look after if you have changed nothing in After Effects/Adobe Premiere prior to the issue.

Thanks Mylenium for the quick answer and taking the time to help and resolve the issue. Case closed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 22, 2023 Apr 22, 2023

Copy link to clipboard

Copied

LATEST

right click, interpret footage... easy peacy

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines