Anchor Point Snapping in 3D

Community Beginner ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

Hi all,

 

I cannot seem to be able to snap the anchor point of a solid layer using the Pan Behind tool once I have changed my Solid to a 3D layer. It snaps quite happily in 2D, but once I get into 3D space I can move it but not snap it.

 

Has anyone got any ideas of what I might be doing wrong/what settings I need to alter?

 

Many Thanks in advance

TOPICS
How to

Views

430

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

That's a limitation of the process. AE's snapping is generally not that great and some scenarios simply fail. If yoou know where it needs to go, just dialling in the numeric values is a more efficient use of your time than trying to rely on the snapping.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 04, 2021 Oct 04, 2021

Copy link to clipboard

Copied

I remembered doing this exact process two years back. Tried to reattempt in CC2021, and discovered I couldn't. But after checking, it is possible in CC2019.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 04, 2021 Oct 04, 2021

Copy link to clipboard

Copied

And after attempting again in CC2021, I see that it is possible here as well. The new gizmo makes it a little more difficult. Using the pan-behind tool and hovering over the gizmo's center vertex works. The pan-behind tool icon will show up, but now competes with the gizmo's XY.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 25, 2022 Jan 25, 2022

Copy link to clipboard

Copied

Yes this is very inconvenient, I wish they would bring this feature back

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 14, 2022 Jan 14, 2022

Copy link to clipboard

Copied

Yeah I used to be able to snap the anchor point on 3d layers, now I can just move the gizmo, no snapping. I used the snapping in 3d a lot so it's pretty annoying

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

I'm here for the same reason.

It works in 2D and it used to work in in 3D in older versions also! I have an older version of After Effects installed, just to be able snap the Anchor Points to corners on 3D planes. In After Effects CC however, there is just a large grey dot saying XZ in the center of the 3D selection and you are not able to move the Anchor Point, like you are used to. I have no idea how the grey dot would be useful, but it prevents me from accessing and shifting the Anchor Point.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 25, 2022 Apr 25, 2022

Copy link to clipboard

Copied

Danial5EFD's method works, as long as you use a plain view (e.g. left, frontal top...). While a custom view or a camera is active, I don't seem to be able to select the Anchor Poit over the grey XZ dot. So inconvenient!

XZdot.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 12, 2022 May 12, 2022

Copy link to clipboard

Copied

LATEST

Hi,

 

I had the same problem and i didnt like the 2022 update, i was trying everything to find a fix for this, they are some payed and free anchor point plugins that i know off but i didnt want to use them, so to be short, i found how you can do it in after 2022 without plugins.

The general idea, with the new 3d gizmo that they added you cant click the center so you can do the pinning of the anchor point, at least it looks like that. So to sellect the center you activate anchor point tool, and you move over the the center and you wait the cursor to change to some axis, for my example Z-axis, then i move a bit the currsor slowly till the cursor change again to the anchor point, in that moment you can select the center. I tried it like 100 times and it works every time, you wait to get one axis, you move the cursor to get back to the anchor point tool and you can move the center and do the pin of the anchor point where you want. Please try it few times and see if it works for you.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines