Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Audio shifted ...

Explorer ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

Hi there,

I've got an issue which has occured now in several different video  I set up. I hope there's a solution.

I record voice tracks in Audition and use them in After Effects. Somewhere between second 1 and second 2 there's a short audio shift, as if one of the stereo waves comes later for the length of one or two words than the other wave (you can hear the word twice).
But obviously it's not the stereo thing, I even tried it in mono:

Still the problem is there. The wave in the middle is heard twice.

When I play the video in a loop, often in the second loop (though not always) the problem's gone, the sound is perfect. So is it maybe somehow only a (known?) issue of playing the video bei AE itself, and the video will be okay after rendering?
(I didn't render them yet, because I'm still in the stage of building some standard blocks for later videos.)

Or is there anything else I should do to get rid of that disturbance?

Views

602

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

PS Sorry I should have mentioned, that in Adobe Audition the playback is without a flaw.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

I see a stereo audio track, and you probably don't need stereo.  Use Audition to make it mono.  Even more importantly, don't export compressed audio from Audition.  Make it a wav file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

Funny you say that, because that's exactly what I did. I saved it in a new file to show it to you.

Audition: Mono

Saved as an uncompressed .wav file. Mono.

Imported it to After Effects:

What do I miss? 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

Well? 🙂
No idea?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

Only one.  Check your project settings.  There may be a mismatch between sample rate and / or bit depth.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

Thanks Dave, that was a very interesting hint, never had looked into those before. I set both Audition and After Effects to 32 bit depth now, increased the sample rate in Audition to 48,000 (can I do the same in AE?), but the problem remains.

Instead of

Hello my name is Stefan Finke and this is my video ...

I still get

Hello my name is Stefan FinFinkeke and this is my video ...

(In a better quality now, though.)

Hmmm.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

I'll bet you are not letting the ram preview completely cache. Purge everything (Edit>Purge>All Memory and Disk Cache), then run another ram preview. There are no reported audio bugs in After Effects if your version of AE is up to date.

The video standard is 16 bit 48 Hhz PZM uncompressed WAV or AIFF. Higher bit depths don't generally hurt you but AE isn't an audio app so you are not going to be doing things like critical EQ and noise reduction in AE so you don't really need 32bit files. They won't hurt.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

Thanks Rick, I purged 5,9 GB of disk cache - I can't image where this weird size comes from, I installed the suite only 3 weeks ago (yes, it's more or less up to date). The problem remains.

New finding: I thought the distortion occurs only in the beginning of the respective video, but now I see/hear it occurs every time after 1-2 s, when I start the preview - independent of where in the video I start the preview.

So maybe it's just the preview mechanism and not really an issue, when I render the videos. (I will tell here to close this thread correctly when the first video is ready.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

Oh, you actually expect After Effects to preview flawlessly!   Good luck with that one! 

Give it a couple-three cycles through your work area before audio syncs up with video.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

Ahhhh, good hint!
Ok, then this is clear and understood.

Thanks everybody!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

AE's Timeline always displays mono audio files as a stereo track, ie. you will see both a left and a right track.

On your issue, go to Preference>Previews to enable the option, Mute Audio When Preview is Not Real-time. Does this help?


Motion Graphics Brand Guidelines & Motion Graphics Responsive Design Solutions
Development | Consulting | Training

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

Hi Roland, thank you!
I tried your suggestion and restarted AE after changing the settings. Unfortunately it doesn't solve the issue.

At least I am getting to know the several functions of AE better this way. 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

The easiest way to know if you are having a real audio problem instead of a preview problem is to add your problem comp to the Adobe Media Encoder (Alt/Option + Ctrl/Cmnd + m) and choose h.264 encoding and one of the presets that match your frame size. YouTube 1080p HD would be a good one. If the render turns out just fine then you are having preview issues. Most newbies want AE to act like an NLE and playback their comps in real time with little or no waiting. AE has never done that, neither has any compositing app when you start pushing it. Don't expect real-time previews that run the length of your comp in the near future.      

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

Thanks so far Rick, I rendered the composition with Media Encoder. Result: Issue not solved.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

1) Which version of AE are you using?

2) Do you have the same issue with other WAV files?

3) Do you have issues when previewing the WAV file in the Footage Panel?

4) Do you have issues with the WAV file in PremierePro?


Motion Graphics Brand Guidelines & Motion Graphics Responsive Design Solutions
Development | Consulting | Training

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

Thanks for asking, Roland.

1) 15.1.1 (Built 12) - probably the latest version.

2) Same issue with other WAVs, yes.

3) Issues playing in the Footage Panel - I had to test it. The answer is: No. - Are you on to something here?

4) No issues in PremierePro.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

Trash your AE Preferences. See if this helps.


Motion Graphics Brand Guidelines & Motion Graphics Responsive Design Solutions
Development | Consulting | Training

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

Yes, done. But no, it doesn't.

Thanks so much for searching a solution with me, Roland! But meanwhile I tend to like David's reply:

Oh, you actually expect After Effects to preview flawlessly!   Good luck with that one!


Maybe it's just a program hiccup, and since the file runs flawlessly in PremierePro - perhaps I should leave it as is?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

So, things work well only after the Timeline Preview cycles through at least once?

I'm just curious what sort of audio hardware you are using - please take a screen grab of Preferences>Audio Hardware.


Motion Graphics Brand Guidelines & Motion Graphics Responsive Design Solutions
Development | Consulting | Training

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

Yes, usually the second cycle goes well. 


In: Blue Yeti

Out: Internal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

Set all audio settings to 48Khz!

I doubt you have enabled the option Mute Audio When Preview is Not Real-time in Preferencs>Previews.


Motion Graphics Brand Guidelines & Motion Graphics Responsive Design Solutions
Development | Consulting | Training

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 16, 2018 May 16, 2018

Copy link to clipboard

Copied

Funny, you just had told me to delete the preferences. Of course now it's on 44.1 KHz again, and of course the Audio etc. was not muted.

So don't doubt what I am saying, instead give consistent hints. I was just following your "advice".

Don't worry, it won't happen again, funny boy.

48 KHz - redone.
Mute Audio ... done.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2021 Jun 06, 2021

Copy link to clipboard

Copied

LATEST

Hey Stefan,

I was just wondering if you ever got this resolved. I'm having the same problem on AE 2020 and 2021.

Thanks,

Joe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines