Blur effect in precomp do not work in main comp when masking

New Here ,
Apr 06, 2022 Apr 06, 2022

Copy link to clipboard

Copied

Hello community,

 

I run into awful problem. I have some effects (like gaussian blur) on my animation, which is in pre-comp. The 3D-animation did not work in main-comp, so I skipped it. But its got text animation on it which I cannot skip. I need to reveal the pre-comp-animation in main-comp, by using masking. The problem is, the pre-comps FXs (like the blur) do not work in main-comp when I create a mask. The FXs disappear. And they reappear when I delete the mask. I need to do the masking in main-comp. I´ve tried shape layer masking and layer masking (and inverting), and it doesn´t matter if the layer mask is on "add" or "subtract". Nothing seems to get me around this problem.

There has been plenty of trouble already and this is my "plan C", or "plan D" already. I´m running out of plans. For some reason the link between main-comp and pre-comp does not work propely. Please, does anyone know, why effects won´t work with mask and is there any alternative solution?? Thank you.

TOPICS
Error or problem , How to

Views

47

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 06, 2022 Apr 06, 2022

Copy link to clipboard

Copied

Turn off the collapse transformations switch. I would suggest you study up on how layer switches affect rendering order and all that. For anything else screenshots would be more useful than even the most verbose descriptions.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

LATEST

Thank you Mylenium for the reply.

Unfortunately I cannot turn off the collapse transformations switch in main-comp, because it turns off the pre-comps FX in the main-comp. The same issue is with the masking in main-comp. It too turns off the pre-comps FX in main-comp. I got to talk to one AE-pro about this problem and he said it´s gotta be due to a bug. This isn´t supposed to happen. I have 18.1 AE version, which had bugs according to him. I´m still working with this old version, cause I have to be cautious due to my quite old computer. Adobe apps newer versions keep demanding more juice out of PCs, you know. However, I´m at "plan D" now, because of the time table. Anyways, thank you for the input!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines