• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Can't drag keyframes of presets or effects

Engaged ,
Sep 24, 2022 Sep 24, 2022

Copy link to clipboard

Copied

If I apply one of the basic TRAPS transformations, I can drag those keyframes without a problem. But when I apply an effect or preset, I can't drag those keyframes. I can select them and can delete them but can't drag them. Doesn't matter if I click them or marquee select them. However, I can use Option + Arrow keys to move them. I've seen discussion of this going back three years. Wondering if anyone found a solution.

 

No, the layers aren't locked or have dependencies and they aren't shy. A layer can have a scale transformation and a dissolve effect transformation, and I can drag the scale keyframes but not the dissolve keyframes. What the heck? Running version 22.6.0 on Monterey.

TOPICS
Error or problem , User interface or workspaces

Views

126

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 24, 2022 Sep 24, 2022

Copy link to clipboard

Copied

Screenshots? Comp settings? Sounds like the layers are time-remapped or use temporal expressions that go bust when framerates don't match.

 

Mylenium

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Sep 25, 2022 Sep 25, 2022

Copy link to clipboard

Copied

Below is the comp settings dialog and a track with keyframes that resist the mouse. This layer is a jpg, file size is 1.2 mb. Layers are a mix of mp3, mp4, mov, jpg. Videos are a mix of 29.97, 30 and 60. And this afternoon as I'm editing a project, even TRAPS keyframes on some layers have stopped responding to the mouse. It's random from one editing session to another which keyframes respond to the mouse and which don't.

comp settings.pngkeyframes.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 25, 2022 Sep 25, 2022

Copy link to clipboard

Copied

The only thing your cropped screenshot tells us is that you have created an 18-minute composition and that five keyframes on one layer that start at the layer-in point and extend to about 23 seconds. 

 

AE is not an editing app. Compositions longer than a single shot are rare. We have no idea what properties you are trying to animate or if there are expressions or anything else. 

 

Poor performance could be caused by a lack of system resources, preview settings, composition panel resolution, and other layers in the comp. 

 

If this is some kind of edited photo montage, I would break it up into compositions that are only one or two shots and do the editing in Premiere Pro. Trying to manage all those layers and transitions in an 18-minute comp is going to be a nightmare. It is not what AE was designed to do. The likelihood that you will have render problems goes way up with a long comp. My suggestion, simplify, render the sections, then do the final edit in an NLE. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 25, 2022 Sep 25, 2022

Copy link to clipboard

Copied

LATEST

If it's random across sessions, there's a good chance you indeed simply run out of resources due to the length of the clip as Rick already pointed out. So ultimately it comes down to the same steps as always: Check your hardware acceleration settings and reign in the cache. In particular the latter might be a good idea as extensive cache I/O can easily gobble up all bandwidth and eventually this will break and dissociate the cache. Keep it to the bare minimum. Also turn off multiframe rendering of course.

 

Mylenium

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines