• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

CC Repetile creating a thin gap

New Here ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

This is the screenshot of my project. You can see a basic rectangle and an 'asset' (Both imported from AI using overlord).

The only effect used is CC Repetile and the basic rectangle is just one single shape, the 'asset' is split into groups within the layer contents.When using CC Repetile effect on them, it creates a thin gap in between.

However it should be noted that, when I use a shape created within AE, this problem doesn't occur.

I tried to apply the effect after pre-composing, but that didn't remedy the issue. 

If you require anything more for a deeper diagnosis, I would be happy to provide.

(The same settings for effects are used for all the shapes, only that the Expand Right values  differ for each)

Thankyou for taking the time to assist.

Repetile Bug.jpg

TOPICS
Error or problem

Views

5.7K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

Not sure why this problem occurs, I'm getting the same problem with my own AI files converted to shape layers. Anyway, you have an alternative. Shape layers can be cloned using the repeaters. If you expand your shape layer, select the content. and with that little drop-down at your right select repeater. The repeatear lets you create copies of your shapes and move them to the right avoiding that cc repetile issue.

 

I will try a couple of things with AI files and write later on.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 31, 2021 May 31, 2021

Copy link to clipboard

Copied

Thankyou for that solution!. Will be happy to know what your findings will be later.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 14, 2022 Oct 14, 2022

Copy link to clipboard

Copied

I have the same issue with MotionTile and RepeTile and to fix it, I precomped (nested) the video layer (it could be any layer) and applied the Transform effect with Scale set to 101% (it won't show since the layer is already at comp size). Then in the parent comp I added the RepeTile effect and that got rid of the black/blank borders.

 

Adobe, PLEASE FIX THIS. I see posts about it from 2018. Seriously no new features just focus on no crashes and proper workflow.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Aug 14, 2023 Aug 14, 2023

Copy link to clipboard

Copied

Still waiting for this fix!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 14, 2023 Aug 14, 2023

Copy link to clipboard

Copied

If you are having a problem with Reptile when using AI files, then the problem is in the AI file. The artwork does not line up to the pixel grid, so the edges are interpreted.

 

The fix is to open the Illustrator artwork, go to the View menu, turn on Pixel Preview, and set the project to Snap to Pixel. Now set the viewing magnification to 400 or 800% and fix the alignment of all the horizontal and vertical edges in the artwork. That should solve your problem.

shapToPixel.gif

Fix the artwork and you fix the problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Aug 14, 2023 Aug 14, 2023

Copy link to clipboard

Copied

Not using AI file

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 14, 2023 Aug 14, 2023

Copy link to clipboard

Copied

The same thing happens with a pixel-based file if it is not lined up with the pixel grid or if there are anti-aliased edges. If it is a video and the frame size is an odd number of pixels, you can end up with the same problem. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Aug 14, 2023 Aug 14, 2023

Copy link to clipboard

Copied

I am using an image layer with a mask and it adds a thin gap and has always done this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 14, 2023 Aug 14, 2023

Copy link to clipboard

Copied

Masks antialias by default. If the mask path is not exactly on the edge of the pixel grid (zoom in to 400% or more) you'll get semi-transparent pixels, and that is what gives you the edges. Try expanding the edges of the mask by 1 or 2 pixels.

 

Just tried with a mask and there is a gap. I'm not sure if it is a bug or a design feature. 

 

If you pre-compose your masked image and set the new comp dimensions to the same size as the masked area, RepTile will work with the pre-comp. That might be a workaround for your situation.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 15, 2024 Jan 15, 2024

Copy link to clipboard

Copied

LATEST

Late to this thread, just ran into this in v23.6.2. Have not checked v24 or the Beta yet.

I tried all the methods listed on the page; Mask+Repetile worked at first but my shape layer is moving and I needed motion blur, which added the gap right back. So what finally worked was to pre-comp the shape layer and make sure it was cropped right to the artwork with no gaps on the edges, then Repetile it back in the main comp and add the transform+motion blur there. 

I met some of the After Effects team at MAX, I might try to bring this up as a bug to fix next time we chat.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines