Content Aware Fill always generates in distorted result

Community Beginner ,
Mar 04, 2022 Mar 04, 2022

Copy link to clipboard

Copied

I can never get Content Aware Fill to work. I watch all these tutorials online where people just create the mask and hit the button, and their computer fills in the results perfectly, yet every time I try to use it, the image is distorted. I'm even trying to use it for something incredibly simple: removing a piece of gaff tape in the background, and the function can't seem to figure it out. Here is a video showing my attempts:

https://youtu.be/fUII3Y_DL7Y (it's easier to see if you switch to 4K)

 

I've tried just creating the mask and hitting generate fill. I've tried creating reference layers every few frames that I fill in using photoshop. I've tried using THE SAME reference layer in different spots (repositioned). No matter what I do, the result at some point assumes that the background is moving around more than it actually is and it distorts to correct itself. 

 

Does anyone know what I'm doing wrong? Is content aware fill not meant to remove piece of tape off a surface? Is it because the surface is too complicated? Are the results going to be the same if you run it on a different computer? Or is there something about your computer's CPU or GPU that determines the results. Because sometimes I feel like my computer is just dumb. 

Appreciate any help you can offer!

TOPICS
Performance

Views

35

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation