Exporting Still TIFF with Straight Alpha causing weird reposition to upper left

New Here ,
Apr 22, 2022 Apr 22, 2022

Copy link to clipboard

Copied

So I have some toolkits that render still frames as TIFFs for Avid edits. The Avids like straight alphas. They all render out pushed to the upper left. Seems to crop to wherever the rgb data ends, but still maintains the full frame size, so it is like the element is completely repositioned up to the left. Strangely, this doesn't happen with premultiplied alphas, only Straight (try one quick, it's crazy). And it doesn't matter if LZW compression is chosen or not, etc.  

 

Btw, these toolkits worked fine with older After Effects (15 and below).

The solution is to render out TGAs, but I've always liked TIFFs.

 

Why did they change this? And can they put it back plz?

TOPICS
Error or problem , Import and export

Views

65

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 22, 2022 Apr 22, 2022

Copy link to clipboard

Copied

Screenshots, exact specs, system info.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 28, 2022 Apr 28, 2022

Copy link to clipboard

Copied

Hello, this does seem hardware specific, didn't happen on my laptop, so, hmmm...

Here are specs and screenshots:

After Effects Version 22.2.21
HP Z840 Workstation
NVIDIA Quadro M6000 24GB VRAM
Intel(R) Xeon(R) CPU E5-2660 v3 @ 2.60GHz 2.60 GHz (2 processors)
128 GB Ram
Windows 10 Pro (Version 21H2)

PaulK__0-1651157172226.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 28, 2022 Apr 28, 2022

Copy link to clipboard

Copied

Any chance you've accidentally messed up the import settings on one system? I vaguely remember Avid having some weird import options. From the looks of it, it is cropping the visible content, which would confirm my suspicion.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2022 Apr 29, 2022

Copy link to clipboard

Copied

Thank you, but this is a grab of the rendered tif file imported back into After Effects. It also looks this way in image viewers, photoshop etc. AE seems to be cropping it on render, but only for tif files.

 

Apparently this has been mentioned in other posts here as well, for tifs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 29, 2022 Apr 29, 2022

Copy link to clipboard

Copied

LATEST

Ah, I see, so perhaps it's really a genuine bug. I guess TGAs it is then for a while now until this gets fixed...

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines