Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Full Screen After Effects 2018 Not Working

Engaged ,
Oct 31, 2017 Oct 31, 2017

Copy link to clipboard

Copied

Since upgrading to After Effects 2018 and High Sierra, I can no longer fullscreen to a second (or third) monitor. In previous versions, I could create a new comp-viewer, drag it to another monitor, hit command+\ and it would fullscreen the comp viewer without a menu bar. Since upgrading to the latest version, it flashes full screen for a second and then goes right back to windowed mode on my secondary monitors. This is a huge part of my workflow and very frustrating to see it stop working.

You can use Mercury transmit as an unlocked comp viewer, but you cannot have multiple monitors with multiple locked comp viewers.

I have tried this on four computers running Mac OS High Sierra and have tested with CC2018 and CC2017

From After Effects keyboard shortcuts reference:

Resize application window or floating window to fit screen. (Press again to resize window so that contents fill the screen.)

I have contacted adobe support but they didn't understand what feature I was talking about... Extremely frustrating.

Any solutions out there that doesn't mean stepping down all my systems to 10.12?

Views

2.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 13, 2017 Nov 13, 2017
Hey cam3LDNYC, A bug has been filed for this issue. Thanks,Rameez

Likes

Translate

Translate
Adobe Employee ,
Nov 01, 2017 Nov 01, 2017

Copy link to clipboard

Copied

Hi cam3LDNYC,

Thanks for a detailed description!

Since upgrading to After Effects 2018 and High Sierra, I can no longer fullscreen to a second (or third) monitor.

Do you experience this behavior on your primary/main monitor?

I'm able to repro this on my test machine, even on the primary monitor.

I tested After Effects CC 2017 & CC 2018 on macOS 10.12.5 & 10.13. Since AE CC 2018 doesn't exhibit this behavior on macOS 10.12.5, this looks like an OS-level bug to me. Let me report it to the product team. 

Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 01, 2017 Nov 01, 2017

Copy link to clipboard

Copied

Yes, this behavior happens for all window types on all monitors (including primary).

It does seem to be an OS behavior issue - but Mercury transmit works so we know the functionality is there. Someone just forgot to check this specific and (very useful) feature.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 13, 2017 Nov 13, 2017

Copy link to clipboard

Copied

Hi Cam3LDNYC,

Please file a bug here. We'll investigate this issue.

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 13, 2017 Nov 13, 2017

Copy link to clipboard

Copied

Hi Kevin,

I have filed a bug report

I have called

I have posted on forums

Some acknowledgement from Adobe about fixing for the next point release would be great

Ive had to lug around a third computer for when I need this feature and it is infuriating.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 13, 2017 Nov 13, 2017

Copy link to clipboard

Copied

Hey cam3LDNYC,

A bug has been filed for this issue.

Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 15, 2017 Dec 15, 2017

Copy link to clipboard

Copied

Has there been a fix for this??? ... Same problem here. This is infuriating and wasted hours of my time!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 09, 2018 Jan 09, 2018

Copy link to clipboard

Copied

Also curious whether this has been fixed, or addressed. Major issue for my JOB, guys!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 09, 2018 Jan 09, 2018

Copy link to clipboard

Copied

Unfortunately No... I have had to revert back to AdobeAfterEffects CC2017... What a disappointing release from Adobe!

If anyone knows of a fix for this, other than not updating to CC2018, please share...Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 09, 2018 Jan 09, 2018

Copy link to clipboard

Copied

I'm having the same problem! ... I've already saved a lot of work with the new version so difficult to revert back. I do notice that when the video freezes up and I am forced to close down and start again that there is still an AfterEffect process continue to be running in the Task Manager.. You have to close that down and then restart and then hope that you can get about 10 minutes of work done before it freezes up again...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 23, 2018 Jan 23, 2018

Copy link to clipboard

Copied

F.Y.I. As of version 15.0.1 (Build 73), released on 01/23/17, the problem has been fixed. I am no longer seeing the crash and the comp viewer can be full-screen on an external monitor.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 05, 2021 May 05, 2021

Copy link to clipboard

Copied

LATEST

Update 2021

Running AE 18.1.0

Running Mac OS 11.2.1 (Big Sur)

 

To run fullscreen second monitor in after effects

  1. Disable "displays have seperate spaces" in Mission Control system preferences
  2. Log out and log back in
  3. Make sure no other apps are using the hotkeys Command+\ and Command+/ (I.e., 1Password)
  4. Make a comp viewer for the desired comp you'd like to full screen.
  5. Drag comp viewer over to second monitor
  6. Click on comp viewer and press Command+\ (this will full-screen it)
  7. Click on comp viewer and press Command+\ (this will fit the content to the screen)
  8. Optional Click on the comp viewer and press / (this will have it fit the comp to 100% - if your comp is the same size as your screen, say for Projection Mapping, then this will work for you). 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines