• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

How do I make the camera automatically frame up perfectly on a comp in 3D space?

Explorer ,
Dec 28, 2023 Dec 28, 2023

Copy link to clipboard

Copied

Say I've got various precomps in differing positions, depths and rotations in 3D space, and I want the camera to fly from one to the other, automatically rotating itself as necessary so that when it lands, the comp is perfectly framed square-on. What's the correct workflow to do that?

I used to use VideoCopilot's excellent "Sure Target" plugin, that let you assign up to 99 layers as camera targets and animate the movement between them very easily, but that was broken a while back by AE updates and it looks like VC aren't going to fix it. There doesn't seem to be any kind of equivalent camera control plugin out there either.

TOPICS
How to

Views

76

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 28, 2023 Dec 28, 2023

Copy link to clipboard

Copied

I just downloaded the Sure Target 2 plugin to try it out, and to make it work, you need to use the Legacy Extendscript engine.

 

screenshot.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 30, 2023 Dec 30, 2023

Copy link to clipboard

Copied

LATEST

I've done that, but it still doesn't work as advertised - it doesn't create the camera and then parent it to the null. I've done that manually, and even then it doesn't necessarily work; you can move the null around but while you can see the wireframe of the camera moving, the actual video in the composition window doesn't move with it.

If you click Refresh Expressions then it might start working, but I'm worried that it might suddenly stop working mid-project and refuse to respond to any of the fixes (like Refresh Expressions or close/reopen the project).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines