Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


how to download previous version for MacOs? Blog post is no longer useful

New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Latest version apparently just support 10.14 MacOs. I have 10.13 and can't update it. Does it mean I can't use After Effects (latest version was working good) any longer? I can't download previous versions and the latest one in the Adobe download center is from 2014. Any help, please? I just need to install what I had a month ago.

Thanks

TOPICS
FAQ

Views

24

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

LATEST

do anyone how to get live support for things like this? I need help ASAP, please, and can't contact anyone.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines