• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

How to enable/disable an audio track

Explorer ,
Jun 21, 2019 Jun 21, 2019

Copy link to clipboard

Copied

Hi.

I have a sequence in AE with several audio tracks, and I want to be able to choose one of them and enable it, disabling the others. Is it possible? How would you guys do it?

Thanks!!

TOPICS
Expressions

Views

3.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jun 21, 2019 Jun 21, 2019

In that case, create a Control Null, add a slider to it, and then add this expression to the Audio Levels of all the audio layers:

thisLayer.index == thisComp.layer("Null 1").effect("Audio-Selector")("Slider") ? value: [-192,-192];

This will compare the index to the layer selected. If they're equal, it will use the value you have set. If not, it will mute the layer by setting its level to -192dB.

Votes

Translate

Translate
Community Expert ,
Jun 21, 2019 Jun 21, 2019

Copy link to clipboard

Copied

The Solo checkbox will only show that audio layer if that's what you're after.

If you want the others to stay muted, then you can simply select all the layers (Cmd + A / Ctrl + A) and then click the audio checkbox so they're all turned off, then turn on the one you want.

Also, since you're posting this in the Expressions forum, are you after an expression approach to this? If so can you elaborate more?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 21, 2019 Jun 21, 2019

Copy link to clipboard

Copied

Yes, thanks.
I need to control this with an expression. Hopefully, to control which track is enabled at the time by selecting a number with a slider.

And I need to have it this way because I want to export this sequence as an Essential Graphics.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 21, 2019 Jun 21, 2019

Copy link to clipboard

Copied

In that case, create a Control Null, add a slider to it, and then add this expression to the Audio Levels of all the audio layers:

thisLayer.index == thisComp.layer("Null 1").effect("Audio-Selector")("Slider") ? value: [-192,-192];

This will compare the index to the layer selected. If they're equal, it will use the value you have set. If not, it will mute the layer by setting its level to -192dB.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 21, 2019 Jun 21, 2019

Copy link to clipboard

Copied

Thank you, sir, that should do the trick.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 25, 2021 Feb 25, 2021

Copy link to clipboard

Copied

I have a similar situation where I have multiple language tracks to a single animation. When I go to render I want the specific language track to play for the correct comp. The issue I am having is that Essenctial Graphics does not allow for changing the audio track in the nested comp. I have found you can only change the multipe tracks in the same comp and will not allow you to nest that in a master comp. Is there something I am missing? I have tried so many ways and I have found no solution. Is this someting we can bring up with Adobe to address and hopefull fix in the future.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 10, 2021 Aug 10, 2021

Copy link to clipboard

Copied

I was experiencing the same issue with Essential Graphics and audio level control, reported it here: https://adobe-video.uservoice.com/forums/911311-after-effects/suggestions/43229589-audio-can-t-be-co...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 15, 2022 Oct 15, 2022

Copy link to clipboard

Copied

Ya, just discovered this bug now. Super frustrating that you can't control audio levels through Essential Graphics. Looks like they closed your bug report without fixing it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 17, 2023 Mar 17, 2023

Copy link to clipboard

Copied

I found one solution! 

Add Stereo Mixer and Checkbox Control to the Audio Layer. Then add this expression to both left and right channels of the Stereo Mixer:

 

if(effect("Checkbox Control")(1)==1) {100} else {0}

 

It's the same solution with checkbox for opacity.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 17, 2023 Mar 17, 2023

Copy link to clipboard

Copied

LATEST

This is a sufficient way to set the audio to be on or off just like the audio level code using the -192db method.  Testing this is magical as long as you are in the same comp but as soon as you try to use Essential Graphics this no longer works. It only plays the audio track that is set as the initial default value, no matter what you do to try and change that value through Essential Graphics it will not change. Using the opacity on different videos will work passing the variable values but not audio.  This is the issue we need Adobe to address and rectify.  Not sure what the backend code is that makes it work for video but not audio it becomes frustrating having to duplicate the same animation several times just for an audio change, and then when you have to make small tweaks and changes you have to duplicate your changes that many times as well.  We need to band together to have adobe help us work smarter not harder. So as long as you are staying within the same comp this method will be fantastic. You can clean the code up to be as simple as on the audio channels just add this: effect("Checkboc Control")*100 ;

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines