image bad quality when importing/exporting mp4

New Here ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Capture-01.JPG

Hello the Community,

I am using AE CS6 on an iMac for more then 4 years.

Last week, I installed AE CC2022 on my PC, Windows10.

I have been terribly dismissed by the image quality of imported mp4 in my AE project.
Some images (not all) are damaged with "displaced" pixels. (see attached screenshots).
This happens when exporting in mp4, via MediaEncoder and also in .mov via the "rendering queue" of AE itself.  I also noticed that the image is also sometimes damaged on the viewport of AE.

Of course, I checked the original .mp4, the video is nice and clean.

Is it a problem to use .mp4 in AE? Is there someting I should do or check before importing an .mp4 into an AE composition?

Thank you in advance for your help!

Jean

Capture-01.JPG

Capture-02.JPG

Capture-03.JPG

TOPICS
Error or problem , Import and export , Preview

Views

75

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Hi Jean,

 

Sorry for your issue.

I've seen this before. It usually happens with the variable frame rate footage. What's the source of your footage? Is it screen recorded or downloaded from Internet? If so, try transcoding it using HandBrake and replace in your project.

Let us know if it helps.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Hello Nishu,

Thank you for your reply.

The integrated video and the AE project (and compo) are all 25fps.

The footage is an original video of mine, made with a 3D rendering software (Blender to be precise).

I have done another test, this time with a new project, created in AE CC2022. (previousely, I must be honnest, the test was done with a file created in AE CS6, opened and converted in AE CC 2022).

This new test with mp4's imported in a "from scratch" new file AE was successfull. The rendering is OK, exported in .avi, .mov and .mp4 (via Media Encoder for the mp4).

So up to now my conclusion is that the problem comes from the conversion/recuperation of a (too) old AE file ... ?

Unfortunately, this would means that I would be unable to open my oldest AE projects, ... unless I re-build them from start in AE CC 2022.  What do you think? Am I right?

Best regards, Jean.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

MP4 is a lossy interframe compressed format that should never be intentionally used as a production format. In almost every case, there is at best one actual frame for every three predicted frames, and that's where the errors occur. A second pass at rendering will also seriously degrade the footage.

 

You should be creating your digital masters by rendering to a frame-based, lossless, and for any serious work, at least a 10-bit production format to avoid these problems.

 

Sometimes transcoding your original MP4 render to a production format will fix a few of the decoding issues causing your pixel shifting.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

LATEST

Hello Mr Gerard,

Thank you for your reply.  I am probably not skilled enough, ... I am an autodidact in the video animation production.

I understand that I should avoid to import .mp4 in After effect because of the bad quality of it.
Could you advise me what kind of video type I should import in AE? Is a .mov recomanded? Is this what you call a "frame-based"?

Concerning the "10 bits production format". Is this concerning the importation into AE or the exportation from AE?
I found a setting about "bits per color" in the "Project settings" in AE (see screnshot below) Is it the place where I can set the "10 bits production format"?

Thank you very much in advance for your help.

Best regards,
Jean

Capture.JPG

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines