• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

importing an illustrator file to after effects

Explorer ,
Jun 19, 2019 Jun 19, 2019

Copy link to clipboard

Copied

ok so im trying to animate my illustrator file in after effects but when i import the file i just get this and no layers. the layer folder only has the illustrator file.

Views

2.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Jun 19, 2019 Jun 19, 2019

ok ive figured it out i just had to fix it by click on the layers panel menu and click release to layers (sequence) in illustrator and importing as regular

Votes

Translate

Translate
Community Expert ,
Jun 19, 2019 Jun 19, 2019

Copy link to clipboard

Copied

There are several ways to do this:

Convert: Right Click Layer > Create > Create Shapes from Vector Layer

Copy Paths: Select shape in Illustrator > Copy > Paste onto new After Effects Solid to create Path

Better methods use Paid 3rd party tools:

Overlord: https://www.battleaxe.co/overlord

- Does a fantastic job of maintaining shapes, position, colors, and layout when exporting from Illustrator to AE.

Explode Shape Layers 3: https://aescripts.com/explode-shape-layers/

- Great tool for exploding shape layers after converted in AE and merging layers do you don't have hundreds of unnecessary layers in dense projects, and you don't have to manually copy/paste solo shapes in each duplicate layer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 19, 2019 Jun 19, 2019

Copy link to clipboard

Copied

Your problem assumes that you actually created layers in Illustrator, which you may not have done.

Very few regular Illustrator users do this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 19, 2019 Jun 19, 2019

Copy link to clipboard

Copied

what do you mean by that? these are the layers i have in illustrator

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 19, 2019 Jun 19, 2019

Copy link to clipboard

Copied

ok ive figured it out i just had to fix it by click on the layers panel menu and click release to layers (sequence) in illustrator and importing as regular

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 28, 2023 Oct 28, 2023

Copy link to clipboard

Copied

LATEST

To import your Illustrator file with layers into After Effects, choose "Composition - Retain Layer Sizes" in the import options. Ensure your Illustrator file is properly organized with elements on separate layers. For more guidance, check out riztagar.com for top tutorials on this topic.

riztagar

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines