JSON in MOGRT not updating when change/updating TSV

Contributor ,
Apr 17, 2019 Apr 17, 2019

Copy link to clipboard

Copied

Does anyone know, apart from deleting all data sources and starting again, how I can switch out updated TSVs and actually get the JSON to refresh in an exported MOGRT?

I am calling text from a TSV

Then making that a MGRT that works in Premiere if AE is installed.

But if I change the cell format or names in the Google sheet, even if I alt replace the TSV, the JSON never updates.

I added a new column, and renamed another one. and the old name is still in the JSON despite deleting all caches and XMPs.

Realised if I deleted all the TSVs and started again (luckily the expressions were linked to layer name) then it updates the JSON.

I know you guys need some JSON love.

Basically I can say that deleting and reimporting seems to be a workaround.

Until I get everyone to use Dataclay!

Views

1.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 15, 2019 May 15, 2019

Copy link to clipboard

Copied

Hi Tristan,

I'm a QE on the Motion Graphics templates team and have been tracking down issues with .tsv files in Mogrts. I think that what you're experiencing might be the same bugs we are currently investigating at their root, but I'd love to get a copy of your Mogrts to test just in case. Would you mind sending me a few of your files via We transfer link or Direct Message here?
Can you also tell me what versions of PR and AE you're running as well as your Operating System?

In the meantime, here are some workarounds that might get you back on track (if you're issues are similar to what we are investigating)"

What *is* working?
- .tsv driven Mogrts exported from 16.0 are working as expected.
- .tsv driven Mogrts created in 16.1 and 16.1.1 will work if the .aep was created in Mac 10.14
- .csv driven Mogrts are working from all the latest releases and on all supported OSs (Mac & Win)

What is *not* working?
- .tsv driven Mogrts exported out of 16.1 and 16.1.1 created on Mac 10.13.6 or Win 10

Known work arounds?
- Export all tsv driven Mogrts from 16.0
- If using 16.1 or 16.1.1 on Mac, update to the latest Mac OS and create fresh project.

- Force AE Mogrt to be rendered via Dynamic Link, which can be done by adding a hidden paint stroke or changing the renderer from Classic 3D to Cinema 4D in the Comp Settings. (Make sure and click "Warn me if After Effects needs to be installed in order to customize the Motion Graphics template").
This will require that AE be installed in order to render in Premiere though.

Thanks for bringing this to our attention,

Dacia

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
May 15, 2019 May 15, 2019

Copy link to clipboard

Copied

HI

You probably already have them, as client I am working with is working with you already.

Thanks for help.

While troubleshooting though I noticed that some new exports still include old fields in the json export, despite them not being anywhere in the AE file.

PS. I have been forcing AE use with Paint as suggested, as I figured you might fix the Cinema4d render thing at some point.

If there is no 3d in the comp then at some point I am sure you will tell Premiere to ignore the 3d renderer!

STicking with paint seems to work.

I thought an obsolete effect would work the same but alas no.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 15, 2019 May 15, 2019

Copy link to clipboard

Copied

Hey Tristan,

We're kind of a giant organization so I'm not sure who your client is working with or who might have those Mogrts, but if you could send me your bad files, I would be able to better diagnose the issue. I'm personally worried that the issue is larger than what we already know. Your project files would be invaluable to better understand the issue. 

Can you also tell me what Operating system you are on and what versions of PR and AE you are using?

P.S. What do you mean by fix the Cinema 4D render thing?
Here is the deal with rendering AE Mogrts in PR.

  • There is a Tiny (and therefore limited) After Effects inside of PR. This allows users to use AE Mogrts in PR without needing to have AE installed. but! unfortunately the Tiny Inception AE can't do everything AE can do. There are effects that it does not render and there are things that it does not support (like Cinema 4D Lite).
  • In those cases, the full version of AE is required and needs to be installed by the user and those Mogrts are rendered via Dynamic Link. This uses the same mechanisms that are used when a user imports and renders an AE Comp in PR or using the "convert to AE Comp" function.


So using anything that is outside of Tiny Inception AE's abilities, needs Dynamic Link. Most of the effects can be rendered via Tiny Inception AE-- CC Particles definitely didn't make the cut and needs DL, as does Paint and any of the C4D functions.

Hope this helps and thank you in advance for your files!

Cheers,

Dacia

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 24, 2019 Jul 24, 2019

Copy link to clipboard

Copied

Hi Tristan!

We fixed the issue with Tiny Inception AE and csv files in our summer dot release v16.1.2. Feel free to reach out and lemme know if you encounter any weirdness.

Cheers,

Dacia

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 02, 2022 Sep 02, 2022

Copy link to clipboard

Copied

LATEST

Hello Dacia,

I got the same problem too.
I am on Mac OS 12.5.1.

After Effects 18.4.6 & 22.6
Premiere 15.4.5 & 22.6
I created a Mogrt with an integrated TSV table.
In Premiere I can't replace the table with a new CSV or TSV file.
If I replace the TSV file in After Effects with an CSV file I can change the data in Premiere.
But I can't use a TSV.
Sorry, I didn't find a newer discussion.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines