Keyframe values not changing automatically

New Here ,
Aug 28, 2022 Aug 28, 2022

Copy link to clipboard

Copied

AAE 2020, have several 3D .mov clips in a composition, with a 2d JPG background, with a 1 node camera added...


1. When setting a keyframe on camera timeline, then move the head to a different time to set a new keyframe, the values do not change automatically to reflect any change in any of the x,y,x properties.

2. If I manually set a keyframe at the beginning, 0 time, of the video clip, move to a later position of the timeline, manually create a second keyframe, the first keyframe then reverts to the value of the new keyframe.

3. The keyframe values are set to Linear.

4. To enhance the quality of the video, I have added Detail Preserving scale and Unsharpen effects to each of the 4 individual .mov files in the composition box

Previous projects worked just fine, keyframe values automatically changed as I moved/altered camera position and orientation using mouse to slide video over, zoom in on someone, swing position around, etc.


Thanks,

Marc Maze

TOPICS
Error or problem

Views

46

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 28, 2022 Aug 28, 2022

Copy link to clipboard

Copied

I have auto keyframe enabled

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 28, 2022 Aug 28, 2022

Copy link to clipboard

Copied

Please verify your workflow. Animating a camera should follow these steps.

  1. Position the camera at the starting position
  2. Enable keyframing by clicking on the Position, Orientation, or a Rotation property in the Camera/Transform properties
  3. Move down the timeline to the time where you want the camera movement to stop or change direction
  4. Adjust the position or orientation of the camera

Follow these steps, and you will have keyframes (the little diamond shape things) in the timeline, and the camera will change position between the keyframes.

 

Only the Active Camera view will render. That is the only Comp View you can use to judge camera position and movement. 

 

User Guide

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 30, 2022 Aug 30, 2022

Copy link to clipboard

Copied

Thanks... exactly what I do... move camera timeline to 1st position, expand out positon and orientation values... when I manually change any of those values, camera POV changes appropriately and a KeyFrame is created... move to second position on timeline, change values again to something different, new KeyFrame created fine

The issue is that before, on previous projects, instead of manually inputing data to Position or Orientation, I could actually move and manipulate the image via mouse in the Preview window and those values would change accordingly.

 

That's not happening at all.

 

If  create a KeyFrame somewhere on the timeline, move to a new position, zoom in to the clip with mouse, nothing changes, new KeyFrame exactly like the earlier one.

 

Thanks,

 

Marc

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 30, 2022 Aug 30, 2022

Copy link to clipboard

Copied

Are you working on the Active Camera? Be sure not to have any of the custom views actives cause this can cause exactly that problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 02, 2022 Sep 02, 2022

Copy link to clipboard

Copied

LATEST

Am working in Active Camera... only view open... have worked around issue OK by moving to point on timeline, using Position only, slide either X,Y,Z values as needed to zoom, move around,etc. and it is working fine now... just don't under stand why moving preview clip with mouse not effecting the Position parameters automatically any more

Thanks for the reply

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

Make your promotional social content with Adobe Express.

Get started quickly with free templates: