• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

MacBook M2 Unable to Run After Effects due to Low Memory

Explorer ,
Jul 25, 2023 Jul 25, 2023

Copy link to clipboard

Copied

Spec's: MBPro M2 Max
96 GB of RAM 
4TB Internal 
macOS Ventura 13.4.1

Using AE (Version 23.5.0 Build 52) for 2D work basically, using animator for text in a 1920x1080 Comp and that's about it. AE is absorbing 87% of my RAM and its extrememly slow chugging throuhg the timeline trying to get through rendering the green bars for simple annimations using tracking and opacity. Its crazy how slow it is. 

** Even when downgraded to AE Ver 22.1.1

I took the same project over to my 13 years old pc - and its didn't even flinch. It blew through the the renders like nothing. 

Side Note for AE Settings are as followed: 
Media & Disk Cache settings are: 
Maximum Dish Cache Size: 200GB 

Memory & Performace 
Installed Ram 96GB
RAM reserved for other applications: 25GB
RAM acailable for AE: 71GB 
:ballot_box_with_check: Enable Multi-Frame Rendering 
% CPU Reserved for other applications 21% 

Project Settings: 
Mercury Software Only 

Using: Open Rosetta is un-checked. 

Cache frames when idle is also un-checked 

Preview is set to Half 

Can anyone throw me any pointers if i have something configured wrong? 

TOPICS
Crash , Performance

Views

1.6K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Jul 26, 2023 Jul 26, 2023

Hi

We're actively looking into reports like this and have something for you to try and report back on. Could you please change the CPU reserved for other applications down from 21% to 5-10%? Please let us know how that affects things.

Votes

Translate

Translate
Adobe Employee ,
Jul 26, 2023 Jul 26, 2023

Copy link to clipboard

Copied

Hi

We're actively looking into reports like this and have something for you to try and report back on. Could you please change the CPU reserved for other applications down from 21% to 5-10%? Please let us know how that affects things.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 26, 2023 Jul 26, 2023

Copy link to clipboard

Copied

Reduce the size of your Disk Cache to 40 of 50. It empties faster and is plenty big to store more frames than the preview will usually render.

 

Set the Memory allocation to other apps to 4, 8, or 12. That's plenty, and AE has never liked an odd number of GB of ram allocated to other apps. Multiples of 4 are best because that's the width of the memory pipeline in modern computers.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 26, 2023 Jul 26, 2023

Copy link to clipboard

Copied

I did as you mentioned. Here are some screen shots of what's happening on my system.... Do you see anything that i might be missing? 

Screenshot 2023-07-26 at 15.46.11 (2).pngScreenshot 2023-07-26 at 15.48.15 (2).pngScreenshot 2023-07-26 at 15.49.21 (2).pngScreenshot 2023-07-26 at 15.50.36 (2).pngScreenshot 2023-07-26 at 15.51.31 (2).pngScreenshot 2023-07-26 at 16.02.40 (2).png
 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 26, 2023 Jul 26, 2023

Copy link to clipboard

Copied

Try setting memory for other applications to 4 or 8 GB.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 26, 2023 Jul 26, 2023

Copy link to clipboard

Copied

After changing all the setting/ preffrences to the above mentioned this is still my memory usage spiking... after a restart of the computer. Screenshot 2023-07-27 at 05.43.13 (2).png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 26, 2023 Jul 26, 2023

Copy link to clipboard

Copied

The minimum can set it to is 12gigs 

Installed RAM: 96.00 GB Current RAM Usage: 73.78 GB Allowed RAM Usage: 84.00 GB
 
Process IDApplication NameMin Needed MemoryMax Usable MemoryMax Allowed MemoryCurrent MemoryCurrent Priority
6863After Effects1.0096.0084.0073.781 - High
6868Team Projects Local Hub0.000.000.000.003 - Low

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 25, 2023 Jul 25, 2023

Copy link to clipboard

Copied

I'm still waiting for assistance to my help - AE is usless on my Macbook M2 Max - just spikes to 90% RAM usage doing 2D work with texts and crashes. I've had to resort back to my 13 year old PC to get the job done. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 25, 2023 Jul 25, 2023

Copy link to clipboard

Copied

I'm on an M2 Macbook Pro, and AE 23 and AE Beta are running just fine. Have you tried opening Preferences/Memory and setting the Ram for other apps to an even multiple of 4GB, like 4, 8, or 12GB? You should also limit your Preferences/Media And Disk Cache to about 40 or 50 GB. 

 

If you have a bunch of other 3rd party software running, that could be causing problems. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 28, 2023 Jul 28, 2023

Copy link to clipboard

Copied

It did absolutley nothing to imporve performance... any other ideas or tips? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 11, 2023 Aug 11, 2023

Copy link to clipboard

Copied

Hello, I have an M2 pro, 16GB RAM and having this same issue. I'm editing 2D footage (HD) with a composition that is 20 seconds long and it can't seem to load fast enough for previewing. Its actually faster if I export to MP4 and watch my composition that way and then go back to edit details. 

 

I'm thinking of downloading an earlier version. I appreciate DVSth's comments and screenshots. I think there is something fundamentally imcompatible with this version of AE and the M1/M2 mac series. I'm willing to post screenshots as well.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 18, 2023 Aug 18, 2023

Copy link to clipboard

Copied

Hi @DVSth & @Kira31526149o45c,

 

Could you try the suggestion in the following thread: https://community.adobe.com/t5/premiere-pro-bugs/issues-with-premiere-23-5-on-m2-ultra-studio/idc-p/...

Let us know the results.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2023 Sep 09, 2023

Copy link to clipboard

Copied

Sorry for the late response! The setting was already enabled for me. Do you suggest un-enabling and re-enabling?

 

I've found that converting my footage to .xmp instead of .mp4, and making the playback screen smaller (12%) has helped.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 01, 2024 Jun 01, 2024

Copy link to clipboard

Copied

LATEST

Can you install the latest version of After Effects and see if the issue persists?

Let us know. I am moving this thread from Bugs to Discussions for now.

 

Thanks,

Nishu

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines