Monterey 12.1 causing issues in After effects

Community Beginner ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

I am having trouble with scripts in AE. They worked fine before Monterey12.1 (in Monterey 12) but since my machine was updated to 12.1, AE cannot open several (most) scripts. I have tried to use the option+shift trick when opening and it doesn't work.


When I open KBar2 - I get the attached error.

 

When I open Explode Shape Layers, Ray Dynamic Color, Ease Copy, Flex + others, I get "Unable to execute script at line 1. null is not an object"

 

My Specs:
MacBook Pro (16-inch, 2021)
M1 Max
After effects 22.1.1 (also tried older versions)
Monterey 12.1 (wiped my machine and reinstalled OS to try to roll back to previous version, but am not able to go back to earlier version of Monterey)


Thoughts?

TOPICS
Error or problem , Freeze or hang , Performance , Scripting

Views

145

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jan 13, 2022 Jan 13, 2022

I turned off dropbox desktop backup and now my AE script work. You advised that on a different thread. 

THANK YOU!

Likes

Translate

Translate
Enthusiast ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

If you've got them from aescripts, make sure you've updated to the latest versions (you can download them from your account page on aescripts) and if that still doesn't work (and you can't do the option - shift method) then open a support ticket for each of them.

This is an ongoing issue that is still being worked on, and this is about the only advice you'll be able to get outside of talking to the creators of those scripts.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

Thanks for responding. I did update and open support tickets with AEscripts. I guess I just have to work without them for a bit. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 13, 2022 Jan 13, 2022

Copy link to clipboard

Copied

I turned off dropbox desktop backup and now my AE script work. You advised that on a different thread. 

THANK YOU!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 13, 2022 Jan 13, 2022

Copy link to clipboard

Copied

LATEST

If anybody is reading this thread and has issues with scripts crashing Ae in Monterey, also see here:

https://aescripts.com/knowledgebase/index/view/faq/scripts-crashing-in-macos-monterey/

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines