Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Objects from preComp still visible despite 0 opacity?!

Explorer ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

I've keyframed the opacity of a precomp and despite this some layers (I figure the ones that have a drop shadow as a layer style) are still visible. 
Is this a bug or am I missing something? I can't remember things behaving like this in the past..
There's no time remaping, and turning off collapse transform and 3D layer makes no difference. 


TOPICS
Error or problem, Preview

Views

265

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

Maybe try re-setting preferences.

Shut down After Effects.

On Mac hold down Option/Shift/Command while clicking on the icon to open the app. Keep holding the keys and let AE make changes.

 

Same for Windows but hold down Alt/Shift/Control

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Thanks, I didn't know about that short cut, however, elements are still visible. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

I replicated your setup and I can confirm that nested layers with a layer style don't respond to the main composition's opacity, but in my case, it happens only when collapse transformations is turned on, when turned off everything is fine

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

For me neither switch resolves the issue. 

But surely, this must be a bug, right?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Yes, it looks like a bug for me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Your screenshot is cropped. I see that layer 3 is a nested comp with a single hold keyframe just a few frames down the timeline but the CTI is out of view so I don't know what is going on in the rest of the timeline. We also don't know what is going on in the nested comp. What happens if your open that comp and turn off layer styles? What happens if you turn off Collapse Transformations? 

 

Post some more informative screenshots but this time embed them please.

* The "Drag & Drop here..." area is buggy and should not be used to share images. Please use the toolbar or just drag your images to the reply field.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 28, 2021 May 28, 2021

Copy link to clipboard

Copied

LATEST

I cropped it because there was nothing of interest outside the cropped area. 
The CTI  was past the hold keyframe 
Turning off Collapse transform or the 3d Switch did nothing. 
Turning off the Drop Shadow Layer style turned the visibility off for that layer..

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines