Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Quicktime recorded file doesn't work in After Effects CC in preview.

New Here ,
Nov 12, 2016 Nov 12, 2016

Copy link to clipboard

Copied

Hello everyone,


I am fairly new to Adobe After effects CC but i'm really enjoying the program. I am currently creating a 2 minute UX video based on the Apple HomeKit app but i'm having major issues with my sound.

So my recorded video files and vectors etc work perfectly with no issue however, I recorded my voice over using Quicktime on my iMac as I need to match my text transitions to the moments I speak but the sound isn't working. Whenever I play the quicktime recording outside of After effects, it works perfectly but as soon as I import it into After effects it stops working in preview. You can see that the sound contains the Waveform but no sound comes out. If you preview the sound file, my voice would maybe appear for like a second at some points of the recording but instantly disappear. You will sometimes have random crackles appear and thats it.

When I render the actual file, the sound is perfectly there and working. So what could be up? This needs to be done by Monday but my sound is stopping me from further editing. PLEASE HELP ME!
Screen Shot 2016-11-12 at 13.11.55.png

As you can see my file is a  M4a as recorded with quicktime but the type is a MPEG.
Any ideas?


Many thanks.

Views

2.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Nov 12, 2016 Nov 12, 2016
this maybe a preview issue. you are playing back your composition but since it's not able to play in real-time you are getting funky audio. since you are fairly new to after effects bare in mind that it does not work like NLE software (premiere for example). read this:  FAQ: How can I play or preview sound (audio)?space bar does not necessarily mean "play with audio".  even when it does play with audio - it doesn't necessarily mean you will be able to playback your composition in real time. if i...

Likes

Translate

Translate
LEGEND ,
Nov 12, 2016 Nov 12, 2016

Copy link to clipboard

Copied

Ae is notoriously bad with compressed audio files. try to export a WAV audio file from quicktime and see it that gives better results.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2016 Nov 12, 2016

Copy link to clipboard

Copied

Unfortunately that didn't work. I just converted it to a WAV file and the same exact thing happens.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 12, 2016 Nov 12, 2016

Copy link to clipboard

Copied

this maybe a preview issue. you are playing back your composition but since it's not able to play in real-time you are getting funky audio. since you are fairly new to after effects bare in mind that it does not work like NLE software (premiere for example). read this:  FAQ: How can I play or preview sound (audio)?

space bar does not necessarily mean "play with audio".  even when it does play with audio - it doesn't necessarily mean you will be able to playback your composition in real time. if it is not able to play audio in realtime it could sound funky or slowed down. you can set it off in the preferences if that annoys you.

check the preview settings

since CC2015, you are able to customize your preview shortcuts.

I use spacebar to play without audio:

notice that it's not caching the frames before it plays. meaning it tries to play in real-time but that depends on my system resources.

these are my Numpad 0 settings:

notice I am caching the frames to disk and only then playing them. this makes sure I get a realtime playback video+audio.

there are many ways to deal with audio syncing with Ae. you can press the period key (.) and this will playback only the audio. sometimes that's enough when you know what you are doing. you can also press CMD and scrub your CTI (current time indicator) and as you do, you will be able to hear the audio and fine tune. caching the frames before playback makes sure you will be able to see video and hear audio in real-time.

see if that works for you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2016 Nov 12, 2016

Copy link to clipboard

Copied

Hello, thanks for all the help.

I've managed to get the audio working by using your numbpad settings and also because I sorted out my 'Mute audio when not in real time preview' setting. It seems to work now but my sound still skips at certain points. It also goes very deep at points, Makes my voice sound strange. my (.) key doesn't actually playback audio, the key does nothing. Same with CMD, they don't seem to work.

At least some of the sound is working now.

Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 12, 2016 Nov 12, 2016

Copy link to clipboard

Copied

my (.) key doesn't actually playback audio, the key does nothing.

period key on the keypad

or Control+. (period) on main keyboard

Same with CMD, they don't seem to work.

Ctrl on Windows, Cmd on Mac. hold it and move the CTI

read the link I sent you to get a better understanding on what to expect when previewing audio in Ae.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Sep 03, 2021 Sep 03, 2021

Copy link to clipboard

Copied

LATEST

my settings are all like that and I still cant hear audio from my clip? I screen recorded from quicktime player and imported it and I have no sound. When I import other videos from my phone the audi works?!! Pls help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines