"invalid menu operation" is displayed, the timeline disappears when reloading

New Here ,
Sep 12, 2018 Sep 12, 2018

Copy link to clipboard

Copied

I use CC 15.1.10 ~ at Win 10 1803.

When editing in the main composition, a warning " Invalid Menu operation " is displayed when layers are selected at an unexpected timing.

Reloading the project file with the warning displayed, the existing timeline of the main composition will not be displayed at all , so the work data can not be saved now.( Preview can be done normally and a new layer can be created, but the layer number will be from 1, Shy is not used)

  Although basic troubleshooting of AE such as version change was executed, it did not solve it at all and it is a state that can not be conjectured due to the fact that occurrence was quite sudden.

  Does anyone know who solved the same kind of trouble or any cause?  Thank you for your help.

Views

22.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 30, 2018 Sep 30, 2018

Copy link to clipboard

Copied

Sorry to say but if you do a bit of searching, you'll soon find this bug has been around for many, many years. I'm using CS6 on Win7 so I'll let you do the math.  Needless to say, don't expect Adobe to come clamoring.  No corporate profit in it.

Since this bug has been around so long, and i ONLY see it occur in AE,  I suspect it has something to do with a quirk in Adobe's scripting or UI and with the OS's basic pointer system that somehow gets confused.  I haven't seen a particular pattern anyway that triggers this.  I usually just save if possible, close project, exit AE & restartit as just closing & reopening the project usually doesn't clear the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 24, 2020 Nov 24, 2020

Copy link to clipboard

Copied

Solving the problem:

1 - Open your Creative Clound Desktop
2 - Search for After Effects
3 - Holding ALT + CTRL + SHIFT (win) or OPTION + SHIFT + CMND (mac), click "open"
4 - A message "Are you sure you want to delete your preferences file?" Will open. Click "OK".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 27, 2020 Nov 27, 2020

Copy link to clipboard

Copied

thanks, it works perfectly for me. cheers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2019 Dec 14, 2019

Copy link to clipboard

Copied

Deleting the prefrence files would solve this problem

C:\Users\YourName\AppData\Roaming\Adobe\After Effects\15.1Capture.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 18, 2020 Jul 18, 2020

Copy link to clipboard

Copied

that didnt do it for me on 17.1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 16, 2020 Nov 16, 2020

Copy link to clipboard

Copied

It worked for me, thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 30, 2020 Dec 30, 2020

Copy link to clipboard

Copied

Thank you, It worked for me on 17.1 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

worked for me so far on 17.5

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 04, 2020 Nov 04, 2020

Copy link to clipboard

Copied

Try reducing your number of layers. That fixed it for me. ( I had 1000+). Maybe the error is memory-overload related.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2022 Feb 26, 2022

Copy link to clipboard

Copied

LATEST
I believe I just found a current problem and solution related to your comment.
 
I'm working on a project that has a lot of compositions.
 
If a composition is used more than 1168 times and I try to right-click it in the Project panel, I get an "After Effects Warning: Invalid Menu Operation" popup.
 
I tested it in CC 2020 and CC 2022 - same bug.
 
I had four different pre-comps used over 1168 times in other compositions. As a test, I just kept deleting the comps that used the pre-comps, and as soon as I deleted enough comps that the pre-comp was used 1168 times or less, the bug went away - no more pop-up and I could right-click the comp and use the menu. This happened for all four of the pre-comps that were used over 1168 times.
 
I searched, and haven't seen anyone else report this specific problem / cause / solution. Will post a new thread and make a bug report.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines