• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Rotobrush masking doesn't match the final output.

Community Beginner ,
Feb 22, 2024 Feb 22, 2024

Copy link to clipboard

Copied

Please, I'm begging you guys, I need this tool for my job and I'm growing so increasingly annoyed by this issue.

1 out of every 5 (or every 50 seconds...) of my renders ends up not matching the masking guides that I made
Like...
This is hard to explain... I seperate my videos into 10 second clips (not enough ram to do anything more than that in 4k....) and please trust me when I say that I go over my rotobrush thoughroughly to make sure that it's the way I want it to be... and regardless of that, 1 out of every 5 (on average) of my clips ends up having some weird area unmasked or masked that I never asked it to mask or unmask... 

This issue is a problem with both the current beta, and the official product, of after effects of course.

And it has been a problem for like at least a year and a half.  I've written about it before in this forum, and still there is no sollution.

I suppose the AI being used to guide the masking is somewhat tied down to like weighted nodes or somehting like that and I get that it can be a bit random but, there has to be some sollution for this, I'm growing so tired of this, like it's barely useable as it is I have to constantly retrace areas that I've already done just to help make sure that the AI will do the render right... and even then it still get it wrong 1:5 times. 

Another issue, is with the Beta version currently, when I'm watching the render occur, and I see that it messes up and I think to myself ok... I guess I need to redo this, and then I try to do so, After Effects ALLLLways crashes, I cannot fix the mistake.  I have to start a brand new project after it crashes.

64GB of ram, 3090 GPU, 10700 intel CPU, windows 10, M.2 drive containing all my files and my folder installation and my cache. 

Begging you guys, please pay attention to this request, please fix this issue, It pains me so much on the daily. 

TOPICS
Crash , Error or problem , Import and export , Performance , Preview , User interface or workspaces

Views

212

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 22, 2024 Feb 22, 2024

Copy link to clipboard

Copied

thoroughly*

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 22, 2024 Feb 22, 2024

Copy link to clipboard

Copied

Are you freezing the propogation?  It's step 9 in the user guide under Roto Brush and Refine Matte.




Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2024 Feb 26, 2024

Copy link to clipboard

Copied

I've never touched that button, didn't even know about it. 
Should I be using it? Like when I'm done rotobrushing everything should I freeze it?

.... shouldn't that be the default?  Why would I ever expect my final result to look anything like other than what I initially asked it to via doing the rotoscope all the way through? 

If that's a button I need to click, for any reason at all, that's certainly a flaw in the design of the program here yeah?

I rotoscope what I want, and I expect it to be exactly that when I hit render... isn't that sensible? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 26, 2024 Feb 26, 2024

Copy link to clipboard

Copied

Yes, once you have the desired results with RotoBrush, click Freeze.

 

I think it's accurate to say that clicking the Freeze button is like telling After Effects, "Hey, this is right.  Stop trying to determine what should or should not be inside the or outside of the results and keep that information cached with the project."  

It could be a "confirm" button, I guess.  If you prefer a different behavior, be sure to post an "Idea" in this forum about it, describing how it would be helpful for how you work.


Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2024 Feb 26, 2024

Copy link to clipboard

Copied

LATEST

well thanks a lot for the information

I'll be back if it doesn't work I suppose.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines