Screen tearing vsync issues on playback

Community Beginner ,
Nov 29, 2021 Nov 29, 2021

Copy link to clipboard

Copied

I recently received a new Lenovo Thinkpad P1 Gen4 = intel 11950h 8 core processor, 64GB RAM, Nvidia 3080 16GB graphics card, UHD 60hz display. I have been using it for After Effects and am getting severe VSync tearing. I have tried all the solutions I can find/think of. I have tried enabling Vsync in both the Nvidia control panel (as suggested elsewhere on this forum) and in the Intel control panel for the integrated graphics. I have also tried dedicating AE to use the Nvidia card only, I have tried running both with/without hardware acceleration. I have ensured all my drivers are up to date. Nothing seems to make a difference. I'm also getting some pretty severe audio lag on playback that is inconsistent - sometimes the audio begins many frames after I begin playback. I'm not sure if the issues are related. To note, AE is certainly utilizing all of the resources as my preview renders are quite fast. There's just definitely a Vsync issue of some sort, as I see tearing during playback or simply dragging the composition window around. Any help would be greatly appreciated.

TOPICS
Error or problem , Performance , Preview

Views

468

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

Well, have you actually checked your cables? Also, if there is such an option, disable adaptive framerates for the display and all that stuff that's only useful for games.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 30, 2021 Nov 30, 2021

Copy link to clipboard

Copied

Thank you for your reply. The display is the built in laptop display, 16.0" WQUXGA (3840 x 2400) IPS, anti-glare with Dolby Vision™, HDR 400, 600 nits. I have tried nearly every relevant setting I can find in the NVidia control panel, intel control panel, dolby vision panel, and system settings. specifically, anything frame rate or VSync related, as well as all kind of power saving features in case those somehow messed with the frame rate. I've tried setting them specifically for AE as well as globally Nothing has made a difference yet. I have a test file that I made that illustrates the problem well, a simple red rectangle on a shape layer translating across the screen with motion blur, you can see the screen tearing very well on the edges of the rectangle as it moves.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 26, 2022 Mar 26, 2022

Copy link to clipboard

Copied

Hey! any news on that? Im not finding a solution yet

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

Old post but had a solution (kind of). Same boat as OP, Laptop with a OLED 4K display (2160P) with HDR support and Nvidia Optimus (Nvidia GPU passes through Intel GPU to display on internal screen) and had a test file setup that had a shape moving across the screen.

 

I had a support session with Adobe and the issue was isolated to CC 2021/2022.

The temporary solution was rolling back to 17.5 (CC 2020) ironically which is not available for users to download.

 

Was assured this would be fixed in a future version as this was the first time they saw the issue, hoping it gets resolved soon because using a 3 year old version of After Effects isn't the best solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

Hi Miba!

 

I was actually able to resolve it myself through the Nvidia Control Panel. Basically the Nvidia CP sets everythingw by default on "CUSTOMIZED BY SOFTWARE". That way you can use your software's control panel and deal with it easely. But in this case.. because of this issue I went and set everything from the Nvidia Control Panel myself. And I tried setting Vertical Sync "ON" and that pretty much fixed it. It's like After Effects wasnt actually triggering it by itself correctly. And went on and changed a few more options as well jsut in case. For instance.. TRILINEAR OPTIMIZATION..was OFF and put it ON. Things that I dont really understand WHY do they do i that way. I mean.. I have an RTX 3090. Biggest GPU on the line. Why would you put that on OFF by default? 

Anyway, I'm now using AE2021 & 2022 likewise with no tiering issue anymore. my advise is that you try that as well. Im guessing you know this but just in case: Right click on desktop... dropdown list should display NVIDIA CONTROL PANEL. On the left you click on MANAGE 3D and you should have 2 tabs. GLOBAL SETTINGS & PROGRAM SETTINGS. Just look for After Effects and I believe Vertical Sync is almost at the very bottom.

On my behalf... AE2022 is MUCH FASTER... but it freezes a lot more than AE 2021

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

Hi Dan,

 

That's great news that worked in your case! 🙂

 

Hope that solution works for other readers that come across this.

 

Do you mind dropping a line letting us know if you have a desktop or a laptop (along with model if applicable)?

 

And to follow up, you guessed right.

Before contacting support I tried what you mentioned both through the Nvidia Control Panel and Intel Graphics Command Center, despite forcing V-sync and Trilinear Optimization After Effects still had the issue on my device. Total headscratcher.

 

I've tried soooo many things...

Things like changing which graphics adapter was used, using different versions of drivers, toggling Hardware acceleration, you name it- I've probably done it.

 

Now I wouldn't mind spending doing more troubleshooting but I'm sure my work would rather prefer me to focus on animating inside of AFX instead of trying to fix it... despite this tearing issue, CC 2022 is insanely fast! Just wish I could enjoy using the software we pay for. (In my case was more stable than 2021/2020).

 

Find it funny that my older laptop (i7 6c/12t, RTX 2060) has no issues while my current work laptop (i9 8c/16t, RTX 3080) preforms like it has the specs of a 2006 office computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

My current setup: desktop-I7 -10700K 8c/16t 4.9ghz, RTX 3090, 48gbRam  (in the process of getting the full set-penny by penny)

 

Likewise. CC 2022 is superfast. But I get weird glithes and just like you said... I dont have the time to deal with them. For instance, when making some playback to correct some animations.. it goes gets mute.. and suddenly no audio is coming out. So I need to clear cache or things like that to correct it. Anyway, sticking to AE 2021 v18.0. 

 

I'm very curious on your workflow. How much tearing you get? does it happen with vectors? with text? with real life video? Frame rate? You did mention you had a virtual session with Adobe and they weren't able to fix it? *facepalm.


 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 26, 2022 Apr 26, 2022

Copy link to clipboard

Copied

Thanks for the details!

Interesting you're having these issues with CC 2022 on a desktop with those specs.

My desktop works and hasn't had any issues (r5 5600x 6c/12t, RTX 3080) wonder if it's Intel related?

(Feel you on the upgrading piece by piece haha, took me 1 full year to get all my parts!)

 

Workflow wise, I generally work with vector based graphics prepped in Illustrator or EXR sequences of 3D renders from Blender and then slam effects on as needed.

Comps are usually 1080P 30 or 60 fps.

 

Just loaded some video files into AFX and it worked fine, no tearing.

If I juxtapose a vector file on top and have that animate, that tears but the video file playing is a-okay.

So seems to only happen with vectors.

 

In my last message, noted that 2020 didn't have the issue. Well, surprise it does. During the virtual session, the performance of 2020 was so slow from RAM preview it wasn't moving fast enough to be percieved.

 

So to answer your question, nope. Resolution was just a "It'll be fixed in the future".

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

Hey all, for anyone who stumbles upon this issue. I managed to figure this out randomly today when exploring the debug settings.

 

Since Nvidia Control Panel and Intel Graphics Command Center did not work, forcing V-Sync within After Effects resolved the tearing for me. 

 

This can be done by:

  1. CTRL + F12 // CMD + F12 to open the After Effects Console.
  2. Select the hamburger menu icon and enable "Debug Database View"
  3. Search "DS.ForceEnableVsync".
  4. Enable this option
  5. Restart

 

Hope this helps someone out.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

LATEST

Funny, that's exactly what I said above 4 months ago LOL

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines