SDK ProcAmp not compiling on Mac

Community Beginner ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

Hello all,

I've been trying to learn how to build GPU-accelerated plugins for After Effects and I've found the development environment setup is harder than actually making the plug-in! I'm trying to build SDK_ProcAmp and after gettng the build schemes working to debug After Effects, as well as getting the proper Boost and AE SDK paths working. However, the plug-in is only seen in Premiere, not After Effects. This seemed weird so I tried setting the plug-in product path to the AE plug-in folder. This resulted in errors caused by the space in "After Effects" in the chmod and mkdir commands in the Metallib building. Building to the default directory and manually dragging makes the plug-in run completely fine. Anybody know how to fix the bulild? Manually installing the plugin is cumbersome and hard to debug.

TOPICS
SDK

Views

19

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

LATEST

I had this issue as well, couldn't make it build where I wanted it. Could you create an alias from where it does build correctly to your AE plugins dir? I use that for my scripts as I don't want to have to copy them to each individual AE location I have. Unsure if it works for plugins, someone more knowledgable may be able to assist.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines