Shape layers disappear in Cinema 4D Renderer

Guide ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

Hi all,

I'm helping somebody with a Map animation and we've come accross an issue that we can't figure out. It's happening on this particular file so I suspect its a file issue. I've tried the same with other maps and they seem fine. But I'd like to know why its happening. I've tried everything, simplifying it etc. Can't pin it down.

Have reset prefs, cleared all caches, updated to latest version, updated CUDA.

Weird thing is you can see that some of it is OK, some others are not. I'm wondering if it could be an open path somewhere?

So basically, here's the timeline with all non-default properties revealed and a before and after shot of the comp;

Screenshot 2018-09-13 18.57.49.png

Screenshot 2018-09-13 18.58.34.png

Screenshot 2018-09-13 18.58.18.png

Views

1.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Sep 13, 2018 Sep 13, 2018
I GOT IT!the paths are not "closed". this doesn't seem to mind the classic 3d renderer, but the C4D renderer is more strict. setting it to closed, brings back the fill.so lesson for today is - C4D renderer won't put fill if the path is not closed. Classic 3D will. #thebugsyouknow

Likes

Translate

Translate
LEGEND ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

Hey Angie. can you send an aep file with a reduced version of this problem?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

Sure, thanks Roei 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

Here it is 🙂 Roei.aep - Box

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

Forgot to zip it, will do it now!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

here's another link, Box is playing up;

https://adobe.ly/2xbWZnC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

It's kind of weird, I checked your file and it effectively disappears when you activate the Cinema 4D rendering, it only works with Classic 3D. But, I did a test with another project where I have Shape Layers and it does not disappear when activating the Cinema 4D render. I think something happens with the file because I searched a bit and did not find anything strange.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

Yes, thanks for trying it. I get the same result. I tried it with other files - cant reproduce it.

Ive tried so many things; I closed the paths, simplified them, changed the colours, made sure there were no extra artboards, made the file smaller. Im really stumped! Just cant figure it out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

The other odd thing is that with the Europe layer only part of it disappears. So Ive been trying to figure out the sifferences between it and the other countries. Cant fathom it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

I GOT IT!

the paths are not "closed". this doesn't seem to mind the classic 3d renderer, but the C4D renderer is more strict.


setting it to closed, brings back the fill.

so lesson for today is - C4D renderer won't put fill if the path is not closed. Classic 3D will.

#thebugsyouknow
1234.gif

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

You are the man!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

Thank you Byron, I can go to sleep now with a sense of accomplishment

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

Hahaha of course! Great lesson we learned today. See ya.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

Thats a good feeling! Sleep well 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 13, 2018 Sep 13, 2018

Copy link to clipboard

Copied

Thanks Roei. Thats really strange because one of the things I tried was closing the paths in Illustrator before importing the files, so I thought I’d already checked that. I did it by selecting each of the countries that didnt work, and then joining them. Perhaps there were more than one “gap” in each country and I only closed one of them?

I didnt think to check it in After Effects so thats a good shout, thank you Roei 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

LATEST

I can´t close my shape. This button is greyed out. Why?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines