Superluminal Stardust: Not Optimized for Multi-Frame Rendering: Warning

Community Expert ,
Aug 15, 2022 Aug 15, 2022

Copy link to clipboard

Copied

After Effects Warnign.png

Is there a way to disable the warning icon that appears on effects not optimized for multi-frame rendering?

 

1) it's distracting

2) what if theres an "actual" problem that I won;t be warned about because the icon is ALWAYS there.

 

I feel like the only point of this is like a backhanded reminder that  SOME AE effects now support multiframe rendering.  It feels like more of an advertisement than a warning and it would be great if i could turn it off for the reasons I listed.

 

Thanks

 

~Gutterfish
TOPICS
Error or problem , Freeze or hang , Performance , Preview , User interface or workspaces

Views

54

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Aug 15, 2022 Aug 15, 2022

I'm pretty sure there isn't, as it's very likely tied to polling the respective new API function and it pops up whenever there is no response. So presumably even if an effect were still just chugging along in a single render instance it would be considered safe as long as it produced the correct response, but it would still require an updated build. So however you spin it, as long as you have legacy effects in use it won't go away and I doubt the devs would bother to implement an override since

...

Likes

Translate

Translate
Community Expert , Aug 15, 2022 Aug 15, 2022

Solution turned out to be obvious.

Disable multi frame rendering in memory & performance settings.

And at least in the case of Stardust, it not only gets rid of the warnings but also drastically improved

the plug-ins performce and stability.  

 

 

Likes

Translate

Translate
Community Expert ,
Aug 15, 2022 Aug 15, 2022

Copy link to clipboard

Copied

I'm pretty sure there isn't, as it's very likely tied to polling the respective new API function and it pops up whenever there is no response. So presumably even if an effect were still just chugging along in a single render instance it would be considered safe as long as it produced the correct response, but it would still require an updated build. So however you spin it, as long as you have legacy effects in use it won't go away and I doubt the devs would bother to implement an override since in two years it wouldn't/ shouldn't matter, anyway.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 15, 2022 Aug 15, 2022

Copy link to clipboard

Copied

OK. really sucks for Stardust plug-in because is node based. So in a complex set up there's 30 or 40 of them.  One for every node.  Guess I'll just deal with it. 

~Gutterfish

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 15, 2022 Aug 15, 2022

Copy link to clipboard

Copied

LATEST

Solution turned out to be obvious.

Disable multi frame rendering in memory & performance settings.

And at least in the case of Stardust, it not only gets rid of the warnings but also drastically improved

the plug-ins performce and stability.  

 

 

~Gutterfish

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines