Track not working (easiest grid track ever, shapes move everywhere)

Community Beginner ,
Jun 29, 2022 Jun 29, 2022

Copy link to clipboard

Copied

I’m doing what should be the easiest track in the world. Over 318 frames a bevy of monitors comes from offscreen to settling farther away. In order to ease tracking It’s only black and white grids where the screens should be. It works okay once they’re moderately far from the camera, but once they get close the tracks bump all over the place–and this is when there is still a lot of grid still showing, so there should be no problem. I’ve tried turning on Perspective, both large and small motion (large doesn’t work at all), and adjusting min % pixels, and none work. I’ve also tried grabbing varying amounts of the monitors. What am I doing wrong?

The screenshots have the grids on a red solid, which helped–originally they were on alpha (but the black in the screen grids was solid).

I tried switching the comp from 32bpc to 8bpc, which seemed to help (but that might have been coincidental). The source is a 3840x2160 .png sequence (and the pngs are 8bpc+alpha, so the higher bit rate might have been causing trouble–I can always switch it back after the track I imagine).

I’m working on the latest AE on a very stout Mac. The source renders are from iClone (if that matters, which I don’t see why it would).

I also posted this on the Boris forums, but they look to be VERY inactive.drift starts here.JPGlast decent frame.JPGendframe.JPGfew_frames_before_end.JPG

Thanks for any help!

 

TOPICS
How to

Views

18

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 30, 2022 Jun 30, 2022

Copy link to clipboard

Copied

LATEST

Why even track 3D renders, when pretty much every program has options to export some form of 3D data to AE as Nulls or solids? Makes no sense. Otherwise the flaw in your workflow is pretty apparent: In trying to be all too helpful you're screwing with the tracker algorithms. The transparency and harsh contrasts produce unstable features because there's nothing surrounding them to estimate the motion vectors and eventually even minor discrepancies will look liek huge jumps. That and of course there may be intrinsic issues with 3D renders liek scenes being illogaical/ implausible in terms of how a real camera would work. Anyway, at the very least try to track inside the screens, not the edges, then expand the plane. That should improve results at least a bit.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines