• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Unable to play high-frame compositions in realtime with M2 Max

Community Beginner ,
Jul 25, 2023 Jul 25, 2023

Copy link to clipboard

Copied

Hi, I am very unhappy currently with the performance in After Effects. It's impossible for me to play even the easiest animations in realtime for 60fps. It always drops down to 30/60fps. I also realized it also happens with compositions where there's no visuals at all, for example when I try to cut songs in 60 fps to have more control of the timings. It stutters all the way through... Are there any settings I could help to get back to realtime playback? My specs:

macOS Ventura 13.4.1

Apple M2 Max

Memory 64 GB

 

leonk64012967_0-1690268709328.png

leonk64012967_1-1690268721737.png

leonk64012967_2-1690268836332.png

leonk64012967_3-1690268844418.png

Thanks for any tips.

TOPICS
Performance

Views

153

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Aug 28, 2023 Aug 28, 2023

So I was able to fix this issue myself. Seems the external monitor was set to 30 hz refresh rate and therefore not allowing the preview to go any fast than this. I changed it to 60hz and I'm able to play 60 fps comps in realtime. Guess that makes sense but still highly annoying. Can't imagine this to be on purpose especially when using even higher framerates such as slow motion.

leonk64012967_0-1693223797264.png

 

Votes

Translate

Translate
Explorer ,
Aug 19, 2023 Aug 19, 2023

Copy link to clipboard

Copied

After Effects is a program from 1994 or thereabouts. it's never been refactored or rewritten, so, as some might suggest, the only way to be happier here, is to lower your standards. I've never gotten my comps to render at realtime in any version post-CS6, and even then, I only managed it with 1080p, and GPU/MFR turned off. 

Note that adobe can't make the program multithreaded with their level of development, so they throw a single frame-rendering thread on each core. This means each core is separately accessing RAM, and each frame can only render as fast as a single core can do it. You may have spotted from time to time that a frame two to five ahead of the next renders before the next, causing hitching. This is why.

Even when it's playing from RAM, the rest of After effects is largely single-core, and the UI does not use GPU for the most part, so it's sharing its preview and file handling with the MASSIVE calculations needed to load and unload from RAM on the fly.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 19, 2023 Aug 19, 2023

Copy link to clipboard

Copied

as an addendum, I've been able to get slightly better playback by disabling MFR/GPU, and using one 1080p monitor. That seems to work by minimizing the time spent rendering UI, and maximize time spent on the next frame's loading from RAM, but it's VERY system-dependent. Perhaps increasing RAM speeds could help?

though I do the bulk of my work in CS6 now that version 23.whatevs is constantly crashing. It runs smoother anyway, and the new additions are just fixes for issues that creative suite cause in the first place. I can always use resolve to transcode to new standards.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 20, 2023 Aug 20, 2023

Copy link to clipboard

Copied

I was able to play high framerate footage before with my 2019 macbook in the exact same setup with an external monitor. It's just impressive that a new 5k dollar macbook with a M2 is a downgrade in that regard…

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 28, 2023 Aug 28, 2023

Copy link to clipboard

Copied

LATEST

So I was able to fix this issue myself. Seems the external monitor was set to 30 hz refresh rate and therefore not allowing the preview to go any fast than this. I changed it to 60hz and I'm able to play 60 fps comps in realtime. Guess that makes sense but still highly annoying. Can't imagine this to be on purpose especially when using even higher framerates such as slow motion.

leonk64012967_0-1693223797264.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines