Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Updated to AE v18.0 Build 39.... Now All My Mp4 Video Footage Imports Are Green?

Community Beginner ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Since updating to AE v18 all my mp4 files now import as soild green footage?   They also export as green footage in Media Encoder.  These files all worked and previewed fine before updating.   If I rename the .mp4 file extension .mpg, the green goes away and the footage works fine and views  normally?  Having to change the file extension on all Mp4 footage is very inconvient, to say the least.

I have tried completely removeing  and reinstalling AE along with all  adobe products on the machine mulitple times.  Tried going back to previous AE versions with the same result.  All .mp4 files remain unusable without changing the file extension to .mpg?  You can see below the .mp4 file is green in the preview and the same file, with extension changed to .mpg becomes viewable?  Anyone see this issue before or have and idea how to fix? Any help will be appreciated.

kermith85209306_1-1615813611111.png

kermith85209306_2-1615813814434.png

 

 

 

TOPICS
Import and export, Preview

Views

5.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Mar 15, 2021 Mar 15, 2021
Can you please try these steps? - Go to Preferences > Import - Deselect "Enable hardware accelerated decoding" under Video Footage - Then go to Preferences > Media & Disk Cache - Click "Empty Disk Cache" and "Clean Database & Cache" - Relaunch After Effects and import the files again Thanks, Rameez

Likes

Translate

Translate
Community Beginner , Mar 23, 2021 Mar 23, 2021
(THIS FIXED THE GREEN VIDEO and MP4 RENDERING ISSUE FOR ME)Doing the sequence below seemed to have fixed the issue for me.  I had tried doing these steps but in a different order and still had the green screens.  If your having this problem, test it out. Hope it works for you also. YOU MUST DO STEPS BELOW IN THIS EXACT ORDER....Disable hardware acceleration in Preferences/ImportClear BOTH  disk caches in this order Preferences/Media Cashe, and then Preferences/ Disk CacheClose After Effects and ...

Likes

Translate

Translate
Adobe Employee ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Hi kermith85209306,

 

We've had one more user report this in our community.

What happens if you go to File > Project Settings > Video Rendering and Effects and switch the rendering engine? Does it bring any change?

 

Let us know.

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Changing from Cuda to Software Only made no difference, initally.  I went ahead and tried rolling back my Nvidia display driver to an earlier version, and that also made no difference. I then updated back to the lastest Nvidia driver and now the mp4 files playback and show every other frame as solid green.  So,currently it's flashing green frames on and off over the footage, where it used to be just a consatant green for the entire time.  This happens no matter if Cuda or Software only is selected.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Thanks for providing more info.

Which Nvidia GPU and driver version are you on exactly?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Quadra K2000 - driver 461.72 - quadra rtx-desktop-notebook-win 10-64bit-international-dch-whale.exe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

I am getting the same issue with my .mov quicktime files, which previewed fine until the latest V18.0 update and now everything is green.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Hey aaronl32138465,

 

What are your system specs?
Do you have an Nvidia GPU too? If so, which one, and what's your driver version?

 

Let me know.

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

I'm actually working on a MacBook Pro.

 

MacBook Pro (15-inch, 2018)

Processor: 2.9 GHz 6-Core Intel Core i9

Memory: 32 GB 2400 MHz DDR4

Graphics: Intel UHD Graphics 630 1536 MB

 

Not sure if this is relevant to your issue since you're dealing with a different video format. I talked to Adobe customer service for a while. In my case, it looks like the uncompressed Quicktime .mov files I was using for Ae and Pr are no longer supported since Adobe dropped support for the quicktime animation codec in the latest update. I have to go back to the older version of the software or I have to transcode all of my footage.

 

I did notice that when I changed the render engine from "Hardware Accelorated" to "Software only", some of my green clips began to appear again, but not all.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Can you please try these steps?

- Go to Preferences > Import

- Deselect "Enable hardware accelerated decoding" under Video Footage

- Then go to Preferences > Media & Disk Cache

- Click "Empty Disk Cache" and "Clean Database & Cache"

- Relaunch After Effects and import the files again

 

Thanks,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

After trying these steps, and opening a new project and importing .mp4 footage the footage previews perfect with no green flashing at all.  But when exporting that project to Media Encoder, the rendered output preview shows green, and if the file rendering actually completes, the rendered mp4 file is completely green..

Opening existing projects resulted in the footage also previewing perfect in some cases but some other older projects some file footage still showed up green.. 

 

All projects either render all the footage as Green or in most cases errored out on encoding. (see below error)

 

- Encoding Time: 00:03:56
03/16/2021 06:56:48 AM : Encoding Failed
------------------------------------------------------------
Export Error
Error compiling movie.

Render Error

Render returned error.

Writing with exporter: H.264
Writing to file: \\?\D:\Rendered Video\testing.mp4
Writing file type: H264
Around timecode: 00;00;32;25 - 00;00;33;20
Rendering at offset: 32.933 seconds
Component: H.264 of type Exporter
Selector: 9
Error code: -1609629695

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Thanks for sharing more info - this is very helpful.

Have you tried rendering directly from the After Effects Render Queue to a different codec/format?

Would it be possible for you to share a sample MP4 file that's causing this on your machine?

Hope to hear back.

Rameez

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Rendering directly from After Effects Render Queue to  AVI codec works fine.  (but only on MP4 files that the footage is viewable and not solid green.

Any attempt to render a H264 /MP4 Video in Media Encoder is exact same error as reported before (doesn't matter if the Mp4 file footage viewable in AE or shows as solid green.

How would you want to share one of the  MP4 files that show solid green in AE preview?  I could upload one to Vimeo and send you link?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

You can upload a sample file to Google Drive or Creative Cloud Files and share the URL here.

 

Thanks again,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

(THIS FIXED THE GREEN VIDEO and MP4 RENDERING ISSUE FOR ME)

Doing the sequence below seemed to have fixed the issue for me.  I had tried doing these steps but in a different order and still had the green screens.  If your having this problem, test it out. Hope it works for you also.

 

YOU MUST DO STEPS BELOW IN THIS EXACT ORDER....

  1. Disable hardware acceleration in Preferences/Import
  2. Clear BOTH  disk caches in this order Preferences/Media Cashe, and then Preferences/ Disk Cache
  3. Close After Effects and Reboot Your PC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Thanks for sharing.

I'm glad to hear that this has solved it for you.

 

Best,

Rameez

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2021 Jun 15, 2021

Copy link to clipboard

Copied

you don't realise that you are an actual legend fella.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 30, 2021 Jun 30, 2021

Copy link to clipboard

Copied

@Rameez_Khancould you please pass this on to the AE engineering team? And maybe have a look at certain graphic cards / drivers? It's been going on for about two update cycles now...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 03, 2021 May 03, 2021

Copy link to clipboard

Copied

Thanks, This helped alot

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2021 Jun 15, 2021

Copy link to clipboard

Copied

you don't realise that you are an actual legend fella.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 31, 2021 Aug 31, 2021

Copy link to clipboard

Copied

LATEST

Thank you! This finally solved my problem. It's ridiculous that adobe still haven't fixed this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 10, 2021 Aug 10, 2021

Copy link to clipboard

Copied

It works! thank you so much!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 21, 2021 Apr 21, 2021

Copy link to clipboard

Copied

Thank you so much, I've been struggling for 3 weeks and this is the only one that worked. Thank you 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines