Upgraded Mac, AE still running slowly...what am I missing?

New Here ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

Hey all,

 

So I upgraded my Mac about 8 months ago. I'm running the 2020 27" Mac (5K) 3.8 GHz 8-Core Intel i7, with upgraded RAM to 80 GB and an AMD Radeon Pro 5500 XT 8GB Graphics card. 

 

Yet playback on AE when editing 4k videos is sluggish, Rotobrush is painfully slow, and forget about adding multiple effects to a clip...it is overly cumbersome to edit at times. 

 

Just wondering if there are settings I could be changing, or something I'm missing here as I seem to have a decent computer setup? 

 

Eventually will probably go for the 27" (or whatever size they do) Mac with the M1/M2 chip but until then...

TOPICS
Performance

Views

33

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

LATEST

Rotobrush is strictly CPU-based and limited by its linear processing and the complex underlying code. It's slow even on the beefiest PC. This is not realyl anything that will change just by upgrading hardware.The rest just sounds like the usual limited Mac hardware vs. the buggy mess that AE has become lately and nothing working as advertised. I know it's not realyl helping, but start by using RAM previews instead of trying realtime playback and all those other old-timey workflows.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

Make your promotional social content with Adobe Express.

Get started quickly with free templates: