VR Output not rendering particle Effects from VR Edit comp, only the part from VR Master Camera

New Here ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

I'm trying to add some particle effects to the space VR/HDRI background I'm making, but the Output only rendered the particles from the VR Master Camera. Is there a way to render out the whole video with particle effects on it?

 

It is also very hard to get a layered effect from different rendering layers since the Master Camera's shape is not square. 

Untitled-1.jpg

Untitled-2.jpg

Untitled-3.jpg

Untitled-4.jpg

    

TOPICS
Error or problem , How to , User interface or workspaces

Views

91

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

VR PrecompCombined and VR Output, with particles only showing in the center part where the VR Master Camera facing at.

Untitled-5.jpg

Untitled-6.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 08, 2022 Mar 08, 2022

Copy link to clipboard

Copied

You need to be much more specific. You haven't even told us what particle system you used, in which of the comps it actualyl resides, what the settings for the particles are and so on. Despite your many screenshots there is basically zero info here, no offense.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

I have 8 particles applied to each area with a nebula on that HDRI picture, so basically there are 8 particle effects with time adjustments.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

I love the fact AE can do VR, but it does struggle with particle systems.  Try this approach:

  • Open VR Master (VR Output)
  • On the layer/precomp VR Conversion, turn off the VR Converter effect
  • Render this comp - possibly as a PNG Sequence.  This will be a render of all 6 precomps, without blending them together
  • Bring this render back into AE and copy the VR Converter effect to it, turning it on.  Then render this comp.
  • If that fails to work, in the project panel, open each of the AE generated precomps and render them separately, then swap the rebders into the comp: VR Master Combined

 

Basically this approach creates extra steps, rather than trying to do a single render with 6 complex particle effects.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

Thank you for the reply! I suppose that you are using the 3D VR Edit, the project I set up was in a 2D Edit set. Tried to add a 3D edit to the same hdr picture/comp, but I'm still not sure if I could adjust the 6 camera angles separately. ALso, how to turn off the VR Converter effect?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

 This is what I see after converting the hdr image/comp with "Add 3D Edit" from VR Comp Editor

Untitled-1.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

One more question about the 3D Edit VR Output. Seems like the output video is not a rectangular 2:1 HDRI video anymore, as the screenshot below. Not sure how to apply the cubmap to the 2D Edit output.

 

Untitled-2.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

Resolved the problem by changing the poi and position values, thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2022 Mar 09, 2022

Copy link to clipboard

Copied

LATEST

So I rendered 6 different layers with only particles on that, changed poi and position values a bit, and screen them with the original output without particle layers on. Now problem resolved!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines