warning that the GPU accelerated ray-traced 3D renderer does not have enough free memory to operate

Nov 01, 2013 Nov 01, 2013

Copy link to clipboard

Copied

[UPDATE: Memory handling for the ray-traced 3D renderer is greatly improved by installing the After Effects CC (12.2) or After Effects CS6 (11.0.4) update.]

You may see a warning message when using After Effects CC (12.1) that the GPU accelerated ray-traced 3D renderer does not have enough free memory to operate.

When the GPU acceleration of the ray-traced 3D renderer is disabled, the CPU version of the ray-traced 3D renderer will operate.

The message about the GPU-accelerated ray-traced 3D renderer not having enough free memory to operate is because of a change in After Effects CC (12.1) to actually warn you when your computer was in a dangerously low VRAM state. In After Effects CC (12.0) and After Effects CS6 (11.0), a computer with very little VRAM could still try to use the GPU accelerated ray-traced 3D renderer, but it would very, very, very often crash. So, now, After Effects CC (12.1) is just detecting the condition that would lead to a crash, telling you about it, and disabling the GPU acceleration until you have dealt with the problem.

So, how do you deal with this low-memory condition? You free up VRAM. This means closing all applicaitons that use GPU memory, which includes web browsers (yes, web browsers these days use the GPU). It also means disconnecting additional monitors, each of which uses a lot of VRAM. In some cases, restarting the computer is necessary.

This is primarily a problem on Mac OS with cards with 1GB of VRAM, such as the GT 650M in the MacBook Pro. These cards on this OS have just barely enough GPU memory (VRAM) to make use of the GPU-accelerated ray-traced 3D renderer under even the best of circumstances. If you want to use the GPU-accelerated ray-traced 3D renderer, you should really be using a more powerful GPU, one with more VRAM.

Note that this has nothing to do with the OpenGL GPU features in After Effects. Details of the GPU features are here: http://blogs.adobe.com/aftereffects/2012/05/gpu-cuda-opengl-features-in-after-effects-cs6.html

Views

104.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 10, 2015 Mar 10, 2015

Copy link to clipboard

Copied

tschreiber0724 wrote:

No, it's the same as Risk's.

Then you shouldn't use the ray-traced renderer at all. The ray-traced renderer is too slow to use on your system. (And the AE team considers it an obsolete feature too.) Use Cinema 4D instead. It comes with your AE subscription!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 23, 2015 May 23, 2015

Copy link to clipboard

Copied

I don't know why an Nvidia Quadro 4000 card with 2GB of VRAM would not have enough memory? I am using a 30" Apple Display, a 13" Wacom Cintiq, and I only have Chrome and AE CC 2014 open. I guess 2GB doesn't go very far these days.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 17, 2015 Jul 17, 2015

Copy link to clipboard

Copied

I have a brand new Mac Pro 6-core with Dual AMD FirePro D700 GPUs with 6GB of GDDR5 VRAM.

I get the error after restarting and emptying cache and not running any other applications.

After dismissing the pop up, it either freezes/crashes or runs very slowly.

I create a black solid, made it a 3D layer, and try to move it back in 3D space, it is EXTREMELY sluggish.

I don't have this problem at all with After Effects CS6. I just bought CC 2015 and now can't even use it.

Screen Shot 2015-07-17 at 5.51.46 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 17, 2015 Jul 17, 2015

Copy link to clipboard

Copied

I wonder if the AMD instead of CUDA-supported Nvidia cards are the culprit?

Have you tried switching your 3D mode from Raytraced back to Classic3D?

Checking the GPU settings in preferences?

Quit all open applications and then launch AE by itself? I know Chrome eats a lot of GPU RAM, but 6GB should be plenty! Are there some obsolete GPU-using plugins that are causing it to crash?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2016 Feb 19, 2016

Copy link to clipboard

Copied

If I can understand this problem -

they basically switched this over this 3D extrusion stuff to be implemented on Cinema4D lite,... because it is obsolete, buggy, and had too many restrictions.

however, the problem with that, is the Cinema4D lite doesn't work with shadows now? I can't get the shadows to show up. I realize that there might be a different thread about that, however Cinema4D lite is supposed to be the workaround so I just want to be clear on this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 19, 2016 Feb 19, 2016

Copy link to clipboard

Copied

I'm not sure what you're talking about. No, the Cinema 4D stuff won't cast shadows onto AE layers, but it will cast shadows on anything in your C4D scene.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2016 Feb 19, 2016

Copy link to clipboard

Copied

Oh forget it. Sorry. It was a setting. I will delete my comment about Cinema4D not working... it was a setting. I was doing a tutorial and several other people had problems and they said it was an update or something... but I just needed to go to options in the viewer and get the shadows... I thought it was default or something the first few times I used it in Cinema4D lite.

Update - Actually the shadows still do not translate into After Effects... I have to create object buffers and composite it after exporting? You'd think that the cinema4D layer would have the shadows, but they disappear in After Effects... and I am not talking about throwing shadows on other AE layers, but just from the cinema4D layer already.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 29, 2016 Feb 29, 2016

Copy link to clipboard

Copied

So my gtx 980 with 6 gigs of ram and 8 gazillion cuda cores is not up to spec? 

Capture.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 29, 2016 Feb 29, 2016

Copy link to clipboard

Copied

ME3D wrote:

So my gtx 980 with 6 gigs of ram and 8 gazillion cuda cores is not up to spec?

Up to spec for what? Are you trying to use the ray-traced renderer, Element 3d, Cinema 4d, or something else? That screen is only relevant for the obsolete ray-traced renderer.

So, if you want to use the ray-traced renderer, we can try to troubleshoot that screen:

You might consider updating your GPU driver.

Have you ever messed with the raytracer_supported_cards.txt file? If so, revert it back to the original.

Also, have you messed with your Windows settings? It looks like you've got Windows Classic Theme going on or something. DON'T do that. It actually requires more system resources and can make things buggy. The default Windows theme is better. If you're concerned about performance, you can disable transparency in the default theme, but it doesn't a huge difference.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 01, 2016 Mar 01, 2016

Copy link to clipboard

Copied

Just to be clear, Szalam, that screen isn't ONLY relevant for using After Effects' ray traced render. There are a lot of plugins that need access to the Nvidia CUDA cores for GPU acceleration.

For Nvidia graphics cards: if your graphics card doesn't show up under the CUDA section, it means your GPU-accelerated plugins probably won't see your CUDA card. Some GPU-accelerated plugins such as Element3D have code that bypasses AE's CUDA support and can access the GPU, but not most. So you'll need to take the steps I posted earlier to activate CUDA support on the Mac. On Windows, your mileage may vary... I imagine there's a similar process but I don't know it. Of course, the first step to take is to make sure you've installed the Nvidia and CUDA drivers on your system!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 01, 2016 Mar 01, 2016

Copy link to clipboard

Copied

ME3D wrote:

So my gtx 980 with 6 gigs of ram and 8 gazillion cuda cores is not up to spec? 

Capture.PNG

You seem to be running into an issue that I've been dealing with a lot lately. However, it looks like you're on a Windows system. I'm on a Mac, but the information below might still be useful to you. It seems that by default, AE is only set up to support "official" Mac releases of graphics cards. Here are the steps I needed to take to allow AE to use the CUDA cores on my GTX 980 Ti (I have the same graphics card).

My theory is that in order to avoid having to support graphics cards that haven't been officially released for MacOS, the default list of cards that are in the AE supported cards text file are probably limited to those that have official Mac versions. So if your card is NOT one of the following, you'll need to take the simple steps below to activate them in AE.

Default list of supported cards:

GeForce GTX 285

GeForce GTX 675MX

GeForce GTX 680

GeForce GTX 680MX

GeForce GT 650M

Quadro CX

Quadro FX 4800

Quadro 4000

Quadro K5000

Step 1:

Right-click After Effects app, and select Show Package Contents.

Screen Shot 2016-02-29 at 11.10.22 AM.png

Step 2:

Find "AEGPUSniffer". Again, right-click this file and Show Package Contents.

Screen Shot 2016-02-29 at 11.10.47 AM.png

Step 3:

Inside the Contents folder of AEGPUSniffer, find the "MacOS" folder and double-click the AEGPUSniffer UNIX executable file.

Note: Even though AEGPSniffer says it's an "application", double-clicking it seems to do nothing. You need to run the UNIX file itself.

Screen Shot 2016-02-29 at 11.11.12 AM.png

Step 4:

Look at the resulting text in your terminal window. Copy the text in "Renderer string" field, without the manufacturer and "OpenGL Engine".

You're looking to copy JUST the model number of the card, with the spelling and spaces exactly as it's listed in this output.

Screen Shot 2016-02-29 at 11.11.57 AM.png

Step 5:

Go back to the contents of the AE application by right-clicking the app again. This time, look in the "Resources" folder for a text file called "raytracer_supported_cards.txt".

Open this text file, paste the text you copied in step 4 to the end of the list, and save it to your desktop using the same name "raytracer_supported_cards.txt". For security reasons, TextEdit won't let you save and overwrite the old one. So then just drag that text file back to the Resources folder and overwrite the previous one after entering your admin password.

Screen Shot 2016-02-29 at 11.13.26 AM.png

Step 6: Close all open finder windows and open After Effects. Open preferences>previews and click on the "GPU Information..." button. You should see something like the following. Before you started step 1, unless your graphics card was already in that text file, you would have had nothing showing up under the CUDA information, and probably not anything under the OpenGL information either, which to my understanding means that AE and AE plugins would not have had access to your CUDA cores!

Screen Shot 2016-02-29 at 12.07.13 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 01, 2016 Mar 01, 2016

Copy link to clipboard

Copied

p.s., I really do have the same graphics card on my Mac Pro at home; those screen shots were from another machine at work that has the GTX 970 installed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 18, 2016 Mar 18, 2016

Copy link to clipboard

Copied

thanks you alot@ !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 11, 2015 Oct 11, 2015

Copy link to clipboard

Copied

Freaking Wow, that's a beast!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 03, 2016 Oct 03, 2016

Copy link to clipboard

Copied

I'm seeing this error with a NVIDIA GeForce GTX 980 Ti 6143 MB graphics - that's 6gb of video ram!!! And no other app is open (like Photoshop / Resolve etc)

WTF Adobe? Please help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 03, 2016 Oct 03, 2016

Copy link to clipboard

Copied

LATEST

From what I understand, Adobe stopped working on the GPU acellerated ray trace engine years ago and why they keep it in the program I don't know. The whole ray trace system is completely unstable and requires way to specific GPU's to work properly (I remember having to be make sure I have time to render multiple times when using it, since it crashed or made faulty frames constantly). I know since its still part of After Effects that you would expect or even feel that is should be possible to use it, but I honestly recommend using something else (adobe should just remove it). Personally Element 3d has replaced whatever I did in the Ray Trace engine with much more possibilities and a better result. And Cinema 4d integration is recommended if you want to go more complex, which is what Adobe wants you to use instead of the ray trace engine anyway.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2