Wave Warp Gaps on Edges

Explorer ,
Nov 30, 2019 Nov 30, 2019

Copy link to clipboard

Copied

I am applying Wave Warp and Turbulent Displace to a shape layer that is larger than the comp, but there are still gaps showing up around the edges. Is there an easy fix that I am missing? Thanks!

 

Screen Shot 2019-11-30 at 5.03.04 AM.png

TOPICS
Error or problem , How to

Views

2.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Nov 30, 2019 Nov 30, 2019

Nothing wrong. You misunderstand how shape layers work. The object inside the shape layer may extend beyond its bounds, but the shape layer itself, i.e. the container that dynamically rasterizes the content can ever only be comp size, which is the only thing conventional raster-based effects see. You can't avoid pre-composing or using larger solids, not shape layers.

 

Mylenium

Likes

Translate

Translate
Adobe Community Professional ,
Nov 30, 2019 Nov 30, 2019

Copy link to clipboard

Copied

Nothing wrong. You misunderstand how shape layers work. The object inside the shape layer may extend beyond its bounds, but the shape layer itself, i.e. the container that dynamically rasterizes the content can ever only be comp size, which is the only thing conventional raster-based effects see. You can't avoid pre-composing or using larger solids, not shape layers.

 

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

Hey Mylenium, 

thanks for this info. I'm also having this problem, however, it's on a pre-comp. The wave warp effect is on a pre-comped layer, then that whole comp is again pre-comped and I have made that pre-comp into a 3D layer so that I can push into it with a camera. I am having the same edge problems even though the Wave Warp effect is one pre-comp in. Doe sthat make sense?

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 02, 2021 Apr 02, 2021

Copy link to clipboard

Copied

Try to disable "Continuously Rasterize" (actually "Collapse Transformations" in this case) on your precomposed layer:

 

1.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 14, 2022 Jul 14, 2022

Copy link to clipboard

Copied

LATEST

For anyone else who has this problem, I solved it by changing the pinning options in the effect panel for the wave effect. I changed it from "None" to "All Edges".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines