Why transparent background is shown as black ?

Explorer ,
Jan 06, 2019 Jan 06, 2019

Copy link to clipboard

Copied

Hi !


I've created a clip on character animator in which my character is speaking solely, with no background on other puppet.

My plan was to take it to After effects and add any background behind it.

but, for some reason, it seems like my puppet has a black background that block any other background layer I wish to put under it on Ae.

Is there something to do here ?Why black.png

Views

16.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Feb 02, 2019 Feb 02, 2019
Pushing your car instead of driving it gets you to the same destination, but it's a lot slower.  Take Rick's advice and read some of the support material on which video formats to use that contain alpha channels.exporting video with an alpha channel (transparency) | Adobe Blog

Likes

Translate

Translate
Adobe Community Professional ,
Jan 06, 2019 Jan 06, 2019

Copy link to clipboard

Copied

How did you render it from character animator?

you need to export it with a file format that supports alpha channel, I would suggest export it as PNG sequence

then reimport the sequence into after effects

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 06, 2019 Jan 06, 2019

Copy link to clipboard

Copied

So I did it and got many many many PNG files.

How do I turn them into a clip whom I can take to Ae ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 06, 2019 Jan 06, 2019

Copy link to clipboard

Copied

You exported to H.264/MP4, which cannot have an alpha channel.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 06, 2019 Jan 06, 2019

Copy link to clipboard

Copied

So what should I do ? how to export this differently ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2019 Jan 06, 2019

Copy link to clipboard

Copied

just import one image onto after effects, you will notice that AE will turn on image sequence by default

then all PNG sequence will be imported as one video footage.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 06, 2019 Jan 06, 2019

Copy link to clipboard

Copied

So I did that and it uploaded a single png photo to Ae. 😕

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2019 Jan 06, 2019

Copy link to clipboard

Copied

Did you check the "PNG Sequence" checkbox when you imported?

Screen Shot 2019-01-07 at 10.14.38 am.png

Also, use the checkerboard transparency view to determine if you have transparent elements in your composition.

Screen Shot 2019-01-07 at 10.17.28 am.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Jan 06, 2019 Jan 06, 2019

Copy link to clipboard

Copied

In File->Import File, when you select the first file in the sequence, make sure the checkbox to import a sequence is checked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2019 Jan 06, 2019

Copy link to clipboard

Copied

Please post a screenshot

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2019 Jan 06, 2019

Copy link to clipboard

Copied

You need to spend some time studying video formats and standards. I would suggest spending some time with the User Guide. Rendering to suitable production formats is a basic production skill you should have. Your only problem is that you did not spend any time learning how transparency works in a video so you picked the wrong format.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 10, 2022 Apr 10, 2022

Copy link to clipboard

Copied

LATEST

Super humble dude.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2019 Jan 31, 2019

Copy link to clipboard

Copied

There are not an alpha channel for AE.

Solution in Photoshop Export/Quick Export as PNG

It works.

If the batch command in Automate doesn´t work and you got a lot of images, then use a batch exporter for PNG with alpha channel. You can use Preview in Mac, open all the images, select all the Images in the sider bar, and an output folder. EDIT/Export (16bytes, alpha channel).

Don´t forget check "alpha channel"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 31, 2019 Jan 31, 2019

Copy link to clipboard

Copied

rubenmontecinos  wrote

 

There are not an alpha channel for AE.

Sorry, you don't know what you are talking about. You just have to pick the right settings. Using Photoshop will work for some things but it's a huge waste of time.

 

Please study the User Guide and take a little time to learn something about video formats and compression.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 01, 2019 Feb 01, 2019

Copy link to clipboard

Copied

But it works, Mr.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 02, 2019 Feb 02, 2019

Copy link to clipboard

Copied

Pushing your car instead of driving it gets you to the same destination, but it's a lot slower.  🙂

Take Rick's advice and read some of the support material on which video formats to use that contain alpha channels.

exporting video with an alpha channel (transparency) | Adobe Blog

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 03, 2019 Feb 03, 2019

Copy link to clipboard

Copied

Thank you, Andrew!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

So, the correct answer is "Go somewhere and learn stuff?" 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 29, 2021 Jul 29, 2021

Copy link to clipboard

Copied

The correct answer is clearly given. The admonishment to go and learn stuff so you understand the process and can solve your own problems in the future is just friendly advice is given by folks that donate their time to help solve problems. Two minutes with the user guide or just taking the default lossless with alpha preset when rendering the animation would have solved the problem. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines