Highlighted

3d Shadows (some) not appearing in Active Camera, while appearing in Custom Views

Community Beginner ,
Sep 17, 2019

Copy link to clipboard

Copied

Hi, I can't understand why some shadows in my 3d scene (cinema 4d rendering) are not appearing. The strange thing is that they appear in Custom Views and also one object is casting shadows in both view while new objects are casting shadows only in the Custom View.
I looked for this problem on google and it looks it happened before but I didn't found any solution.

I attach two screenshot where you can see a phone always casting shadows and a shape layer casting shadows only in the Custom View

problema ombra 2.PNGproblema ombra.PNG

Views

355

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

3d Shadows (some) not appearing in Active Camera, while appearing in Custom Views

Community Beginner ,
Sep 17, 2019

Copy link to clipboard

Copied

Hi, I can't understand why some shadows in my 3d scene (cinema 4d rendering) are not appearing. The strange thing is that they appear in Custom Views and also one object is casting shadows in both view while new objects are casting shadows only in the Custom View.
I looked for this problem on google and it looks it happened before but I didn't found any solution.

I attach two screenshot where you can see a phone always casting shadows and a shape layer casting shadows only in the Custom View

problema ombra 2.PNGproblema ombra.PNG

Views

356

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Sep 17, 2019

Copy link to clipboard

Copied

SOLVED

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 17, 2019

Copy link to clipboard

Copied

In the future please post your entire UI with the modified properties of the layers giving you problems revealed (uu will do it). Cropped screenshots tell us nothing about the workflow or the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Sep 27, 2019

Copy link to clipboard

Copied

Hi there,

 

Glad to know that you got it working. Would you like to share what exactly caused the issue and how did you resolve this so other users can also know?

 

Thanks,

Shivangi

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Sep 27, 2019

Copy link to clipboard

Copied

Yes, apparently the problem was a 2d shape layer I was using as a vignette which was on top of the phone (which has a regular shadow) and under the new 3d object I created because when you create something new it gets created on top of the other layers. So it seems that having a 2d layers between 3d objects interferes with shadows. Is this a normal behaviour or it's a bug? I solved moving the vignette on top of everything.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 18, 2020

Copy link to clipboard

Copied

Hey how about that.

I had the same issue, including the 3D layer being sandwiched between a couple of 2D layers.
Moved it out of the sandwich and all good now!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...