Adobe After Effects cc 2017 - Audio slows down and then speeds up at random

New Here ,
Jun 22, 2017

Copy link to clipboard

Copied

So i just got after effects cc 2017 and it seems that everytime i try to preview my footage. the audio will slow down and speed up at random times,

the footage seems to work out fine but its just the audio its really annoying because im just trying to edit my stuff.

Adobe Community Professional
Correct answer by Gutterfish | Adobe Community Professional

The problem is that your footage is not playing back in real time.  Once the footage is cached & playing in real time your audio will be fine.  Assuming you have adequate RAM to use AE with any efficiency you may also need to purge your cache.  If that doesn't work and your footage is just very system intensive then you might have to temporarily drop your preview resolution down to a half or third or quarter.  The behavior your describing is normal.  At least in every version of AE "post 2014". 

TOPICS
Audio

Views

18.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Adobe After Effects cc 2017 - Audio slows down and then speeds up at random

New Here ,
Jun 22, 2017

Copy link to clipboard

Copied

So i just got after effects cc 2017 and it seems that everytime i try to preview my footage. the audio will slow down and speed up at random times,

the footage seems to work out fine but its just the audio its really annoying because im just trying to edit my stuff.

Adobe Community Professional
Correct answer by Gutterfish | Adobe Community Professional

The problem is that your footage is not playing back in real time.  Once the footage is cached & playing in real time your audio will be fine.  Assuming you have adequate RAM to use AE with any efficiency you may also need to purge your cache.  If that doesn't work and your footage is just very system intensive then you might have to temporarily drop your preview resolution down to a half or third or quarter.  The behavior your describing is normal.  At least in every version of AE "post 2014". 

TOPICS
Audio

Views

18.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 22, 2017 0
Advisor ,
Jun 22, 2017

Copy link to clipboard

Copied

Does this help?

Preferences > Previews > Mute audio when preview is not realtime

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
New Here ,
Jun 22, 2017

Copy link to clipboard

Copied

no sadly, that just makes the audio cut out and play again at random

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Adobe Community Professional ,
Jun 22, 2017

Copy link to clipboard

Copied

The problem is that your footage is not playing back in real time.  Once the footage is cached & playing in real time your audio will be fine.  Assuming you have adequate RAM to use AE with any efficiency you may also need to purge your cache.  If that doesn't work and your footage is just very system intensive then you might have to temporarily drop your preview resolution down to a half or third or quarter.  The behavior your describing is normal.  At least in every version of AE "post 2014". 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 2
Adobe Community Professional ,
Jun 22, 2017

Copy link to clipboard

Copied

Sounds like you are new to Visual Effects and AE. You need to study up on how the UI works and what to expect from the program. AE is not a NLE, was never intended for editing, and us useful only for doing things to shots and short sequences that you cannot do in a NLE. That's it. Please study up and you'll relieve a lot of your frustration. Basic AE

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2017 0
Community Beginner ,
Dec 28, 2018

Copy link to clipboard

Copied

I have the exact same issue as the OP and, guess what, I'm not editing anything, I don't even have any file in the project other than the WAV file. It slows down even when I merely maximize or collapse the layer view. I've got 16GB RAM, 10 of which are for AE, and i'm not running any other software. I've set all the preview resolution options to 1/4, I've checked the "Cache Before Playback" box, and it keeps doing it after caching, I've tried a 6 second WAV file with a 48 kHz sample rate to match the audio hardware configuration. The problem persists. As far as I know, AE isn't intended only to add effects to shots, it's widely used to do animation too. And while animation does not necessarily require video editing, it does often require synchronization with sound, so I don't think it's fair to tell people to "study up" as if they're doing something wrong when all they are trying to do is simply preview audio in real time. The audio is going in all kinds of crazy speeds, and it only happens in the preview.

Besides, there are countless reports of audio problems in AE on the internet, and anyone who's used other softwares can tell this AE behavior is abnormal.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 28, 2018 1
Community Beginner ,
Dec 28, 2018

Copy link to clipboard

Copied

No, that's not the problem. These are slow downs and speed ups that happen regardless of the amount of material you've got in the timeline. To me, it happens even when the only thing I have in my project is the audio file, with all resolutions set to 1/4. People who haven't dealt with this issue will dismiss it as "normal and justifiable AE behavior". But it's not. There is something going terribly bad with the way AE plays audio in preview.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 28, 2018 2
Explorer ,
Jun 23, 2017

Copy link to clipboard

Copied

Gutter-Fish is telling you right. Same thing happened to me and I had to drop my Preview res down to 1/4 until I got things better organized. Like I had multiple clips in my project without any In/Out points set. Once I got those points set, I could increase my Preview res back up to 50%

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2017 0
Participant ,
Oct 30, 2019

Copy link to clipboard

Copied

I'm finding this issue with CC2019. My system is a Core i7 Xeon 20 core CPU, 128gb RAM and a 24gb Nvidia card. My colleague and I putting together clips in AE for use in PP. I'm finding that when I do a RAM preview, even with just an HD 1920 clip playing with speech audio - ie no effects that have to be rendered on the fly - it still slows to a crawl and the audio sounds worse than Sylvester Stallone after 14 pints of beer. 

Now if AE was processing a ton of effects at once, even with 128GB, I would understand the slow down, but this is just an mp4 slotted in over a voice over playing at 1/4

 

So is it because I'm doing things wrong with compositions? The more layers in compositions, the quicker it ram previews?

 

thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2019 0
Community Beginner ,
Jul 28, 2020

Copy link to clipboard

Copied

They never fix anything in that obsolete software. Whenever y to do anything in AE people will start to say AE was not built for this and that ...  

If I Import a footage it will lag, if I work motion graphics and rasterize it will lag... meanwhile unreal engine, blender and  this community is having realtime renders with insane optimisation and graphics, while im stuck  here to try to preview a 16kbps mp3 file on AE.

 

We need another software to work on. What a trashy software...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 28, 2020 1
Explorer ,
Nov 15, 2020

Copy link to clipboard

Copied

I may have found the solution. I was rendering a cached comp (so playback in real-time) and audio kept sounding slowed down. It's an 48Khz 24bit stereo track in a 48Khz project. The problem was the comps framerate of 29,97 drop frame. When I switched it to 25fps, the track sounds perfect. When I switch back and fourth between framerates, I can toggle the problem on and off 🙂 

--> I think AE has a bug where it samples the audio files incorrectly with certain combinations of frame rates and audio sampling frequencies.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2020 3
Community Beginner ,
Nov 23, 2020

Copy link to clipboard

Copied

Seems we are getting somewhere, nice one Zandwacht!   Thanks.

 

First time it's happened to me where a whole mp3 track has imported at the wrong speed.  I had to lower my compostion frame rate to 15 fps for it to play correctly

 

Does seem like a bug.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2020 0
New Here ,
Jan 08, 2021

Copy link to clipboard

Copied

This has definitely been my only solution! thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2021 1
Explorer ,
Dec 09, 2020

Copy link to clipboard

Copied

I've got this figured out on my system after no luck with any of the suggestions in this thread including the so called previous SOLVED solution with no luck there either. The problem is the Audio Sample Rate in Project Settings under the File menu. The default is 48.000 khz which is too high for real time playback and rarely needed for most projects anyway. Change this to 44.100 which is still a very high quality and that fixed it for me instantly. Also keep in mind that if you move your mouse while playing back, that can also cause the audio to slow down, so change your sample rate and get your hands off your mouse after pressing play and you should be good for perfect playback as long as you first buffered the section of your timeline you want to hear in realtime. The problem is not your hardware, and contrary to what some believe, After Effects is 100% meant for realtime playback for any length of timeline that your system is able to buffer. If you can buffer it, it should play in realtime with no lag. The max buffer time is dependent on your hardware and available cache space. Hope this helps.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 09, 2020 1
Explorer ,
Dec 09, 2020

Copy link to clipboard

Copied

In addition to changing your sample rate you'll still need to Edit > Purge and clear your memory cache often. These steps were not neccesary with previous versions but they are now. Until Adobe fixes this, these steps are working for me. Good luck.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 09, 2020 0
Explorer ,
Dec 09, 2020

Copy link to clipboard

Copied

This is going to seem too easy but first thing first, try restarting your computer first before any of the other suggestions. This very simple thing can solve it for some.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 09, 2020 1
Community Beginner ,
Jan 10, 2021

Copy link to clipboard

Copied

I thik this was my issue actually as i leave my laptop on a lot.   Been fine since.  Thanks Spacecorn. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2021 1